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About the ABBYY FlexiCapture Connector for Blue

Prism
ABBYY FlexiCapture enables users to perform high-quality full-text recognition, classify documents,

detect fields and capture their data, and convert files into various formats (e.g. into searchable PDF).

ABBYY FlexiCapture Integration Solution for Blue Prism is intended for sending document files from Blue

Prism to ABBYY FlexiCapture and loading document files and captured data into the Blue Prism robotic

process automation system.

ABBYY FlexiCapture Integration Solution for Blue Prism is provided as two separate solutions, a Multi-

Task Package and a Single-Task Package.

The Multi-Task Package is intended for concurrent processing of multiple documents. Each action in

this solution is used for some type of interaction with ABBYY FlexiCapture.

The Single-Task Package is intended for processing documents one at a time. The program will not

start on a new document before the current document has been processed.

System requirements
Blue Prism side:

· Blue Prism 6.4.2.10610;

· Microsoft .NET Framework 4.7.

ABBYY FlexiCapture side:

· ABBYY FlexiCapture 12.0.2.3042 Distributed or ABBYY FlexiCapture Cloud.

Important! To be able to send documents from Blue Prism to ABBYY FlexiCapture, you need to open
the following port in the firewall to the ABBYY FlexiCapture Application Server: port 80 (if HTTP is used)
or port 443 (if HTTPS is used).

Multi-Task Package
Architecture

The ABBYY FlexiCapture 12 multi-task integration solution for Blue Prism comprises the following

components:

· FlexiCapture 12 – Multitask VBO, which operates on the Blue Prism side. This object provides

various actions for interacting with ABBYY FlexiCapture.

· Blue Prism Processes, which send files to ABBYY FlexiCapture for processing, get processing

results, and work with batches.

· Blue Prism Work Queues, which are required for normal operation of all the processes. The

ABBYY FlexiCapture 12 multi-task integration solution for Blue Prism has the following queues:

MonitorQueue, VerifierQueue, and FetcherQueue. Queues are used for storing the IDs of the

batches with which the processes are currently working.



4

ABBYY® FlexiCapture® 12 Connector for Blue Prism Administrator̀ s guide

· Blue Prism Environmental Variables, which make it easier to set up a connection to the ABBYY

FlexiCapture server when working with processes. The following variables are available: 

FlexiCapture Server URL, FlexiCapture Company, FlexiCapture Username, FlexiCapture

Password, and FlexiCapture Project.

FlexiCapture 12 – Multitask VBO

The FlexiCapture 12 – Multitask VBO offers all the functionality required for working with ABBYY

FlexiCapture 12. It includes two built-in actions, Initialize and Clean Up, and the following actions for

working with ABBYY FlexiCapture:

· Configure

· Create Batch

· Get Batch Stage

· Get Batch Verification URLs

· Fetch Batch Results

· Check If Configured

Configure

This action initializes the FlexiCapture 12 – Multitask VBO with the settings required to connect to

ABBYY FlexiCapture 12. Always run this action prior to using any other action available in the 

FlexiCapture 12 – Multitask VBO.

The "Configure" action accepts the following connection settings as input: the address of the ABBYY

FlexiCapture server, tenant name (optional parameter), user name, password, and the name of a

ABBYY FlexiCapture project. These settings will be saved to the data items for subsequent use by other

actions available in the FlexiCapture 12 – Multitask VBO.

Note: The ABBYY FlexiCapture user must have the roles of Scanning Operator and Verification
Operator for the given project or the role of Administrator. These roles are granted by the administrator
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in the ABBYY FlexiCapture Administration and Monitoring Console.

Create Batch

This action sends files to ABBYY FlexiCapture 12 for processing. For these files, ABBYY FlexiCapture

will create a batch with a unique ID.

The "Create Batch" action accepts the following as input:

· BatchTypeName (Text Data Type) – the name of a ABBYY FlexiCapture batch. This is an optional

parameter. If no batch name is specified, the "Default" batch type will be used.

· Files (Collection Data Type) – a collection of files that will be sent to ABBYY FlexiCapture. This

collection must have a Name field of type "Text" and a Content field of type "Binary".

· RegProperties (Collection Data Type) – a collection of batch registration parameters. This is an

optional parameter. This collection must have a Name field of type "Text" and a Value field of type

"Text".

This action creates a batch of documents with a document corresponding to each input file. The

program then processes this batch and its ID is returned to Blue Prism.

Get Batch Stage

This action gets information about the current stage of a batch by its ID.

The action accepts only batch IDs as input (i.e. BatchId variable of type "Number").
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The outputs of this action are as follows:

· Type (Number Data Type) – the type of the currents stage of the batch. Please refer to the ABBYY

FlexiCapture documentation for a list of values corresponding to the predefined processing stages.

· Name (Text Data Type) – the name of the currents stage of the batch.

· Details (Text Data Type) – a message containing detailed information about the status of the

batch.

Note: Depending on the current stage of a batch, the user may decide on what to do next with the
batch. For example:

· For a batch at the "Import" stage (Type = 100), the user may decide to check its status after a

while.

· For a batch at the "Verification" stage (Type = 500), the user may want to call the "Get Batch

Verification URLs" VBO action for this batch.

· For a batch at the "Processed" stage (Type = 900), the user may want to call the "Fetch Batch

Results" VBO action for this batch.

The "Get Batch Stage" action returns values to Blue Prism that correspond to the current status of

batches.

For example, if a batch arrives at the verification stage, the outputs will be populated as follows:

http://help.abbyy.com/en-us/flexicapture/12/developer/tprocessingstagetype
http://help.abbyy.com/en-us/flexicapture/12/developer/tprocessingstagetype
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Get Batch Verification URLs

This action gets a set of URLs pointing to the Web Verification Station where a batch can be verified by

its ID. It should be called when a batch arrives at the verification stage.

This action accepts only BatchId variable of type "Number" as input.

The output of this action is a collection of verification URLs for the batch.

This action returns to Blue Prism URLs for verifying the batch.

Fetch Batch Results

This action gets batch processing results. It should be called when a batch arrives at the "Processed"

stage.

This action accepts only BatchId variable of type "Number" as input.
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The outputs of this action are as follows:

· A collection of registration parameters with Name and Value fields;

· A collection of document processing results (DocumentResults) with the following fields:

o DocumentId (Text Data Type) – the identifier of the document in ABBYY FlexiCapture;

o DocumentDefinition (Text Data Type) – the name of the Document Definition corresponding to

the document (i.e. its type);

o Files (Collection Type) – a collection of export files for the document with Name (of type "Text")

and Content (of type "Binary") fields.
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This action provides Blue Prism with batch processing results, which can be used in a subsequent

workflow.

Check If Configured

This is an auxiliary action that checks if the "Configure" action has already been called. It is used by the

"Create Batch", "Get Batch Stage", "Fetch Batch Results", and "Get Batch Verification URLs"

actions.

Note: To learn more about Business Object Definition FlexiCapture 12 – Multitask VBO, launch the
Process Studio in Blue Prism, open the properties of the Action item, select FlexiCapture 12 –
Multitask VBO, and click the "i" icon.
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Blue Prism Processes

The ABBYY FlexiCapture Multi-Task Package includes the following processes:

· Batch Sender

· Batch Monitor

· Batch Verifier

· Batch Fetcher

Batch Sender

This process takes files from a folder and uses the "Create Batch" VBO action to send them to ABBYY

FlexiCapture 12 for processing. ABBYY FlexiCapture will create a single batch for each file it finds in that

folder. Next, the ID of the newly created batch is added to the MonitorQueue queue for subsequent

processing in the Batch Monitor process.

Batch Monitor

This is a constantly running process which handles items in the MonitorQueue queue. Using the "Get

Batch Stage" VBO action, it gets the stage of a batch and performs the following:

· If a batch is at the "Exceptions" stage (where they may be placed due to processing errors), an

item in MonitorQueue queue will be marked as an exception. The text of the error message will

be recorded in the "Exception Reason" section.

· For a batch at the "Verification" stage, a new item will be added to the VerifierQueue queue and

the processing of the item in the MonitorQueue queue will be postponed. The element will not be

added to the VerifierQueue queue once again.
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· For a batch at the "Processed" stage, a new item will be added to the FetcherQueue queue, after

which the item in the MonitorQueue queue will be marked as successfully processed.

· For a batch at any other stage, the processing of the MonitorQueue queue will be postponed.

In the Batch Monitor process, there are data items for storing timeout values:

· Iteration Timeout – the time after which the Batch Monitor process will reattempt to get the item

from the MonitorQueue queue if the first attempt failed. The recommended value is 20-30

seconds.

· Other Stage Timeout – the time for which batch status check will be delayed if the batch is

currently at a stage other than "Processed", "Verification" or "Exceptions". The recommended

value is the estimated time for the batch to go from the "Import" stage to the "Processed" or

"Verification" stage.

· Verification Stage Timeout – the time for which batch status check will be delayed if the batch is

currently at the "Verification" stage. The recommended value is at least 2x the estimated time of

verification by the operator. 

You can change any of the default timeout values depending on the current ABBYY FlexiCapture loads.
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Batch Verifier

This process handles items from the VerifierQueue queue, one item at a time. It gets verification URLs

by the ID of the batch and opens them in a browser, where the respective documents can be verified by

the verifier. Once verified, an item is marked as completed.

Batch Fetcher

This is a constantly running process which handles items from the FetcherQueue queue. It accepts

batch processing results and saves the export files created for each document in a batch. Once the

export files are saved, the process marks the item as successfully processed.

Installation

To install the Multi-Task Package in Blue Prism:

1. Run the ABBYY_FlexiCapture_Connector_for_BluePrism.exe file, select a destination folder,

and click Extract.

2. Open Blue Prism - Robotic Process Automation Software and click File → Import.

3. Select the .bprelease file in ABBYY FlexiCapture Connector for Blue Prism\Multi-Task

Package\Blue Prism Release File.

4. Click Next. You will see the following message: "The incoming process has been published. Do

you want to publish the process in this database after importing?". Select Yes for each of the

processes to make them available on the Control tab. Then click Next.

5. Repeat the above steps to import the following additional VBOs from Blue Prism Limited\Blue

Prism Automate\VBO:

o BPA Object - Utility - Environment.xml

o BPA Object - Utility - File Management.xml

o BPA Object - Utility - General.xml

6. Restart Blue Prism.

After importing the .bprelease file and the additional VBOs:

· On the Studio tab, a FlexiCapture 12 Processes group will be created in the list of processes,

which will contain sample processes, and FlexiCapture VBOs group will be created in the list of

objects, which will contain the FlexiCapture 12 – Multitask VBO. The additional VBOs will be

placed into the Default group under Objects.
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· On the Control tab, FetcherQueue, MonitorQueue, and VerifierQueue queues will be created

in the Queue Management group, which are required by the processes.

· On the System tab, FlexiCapture Password, FlexiCapture Project, FlexiCapture ServerURL,

FlexiCapture Username, and FlexiCapture Company variables will be displayed in the

Environmental Variables section of the Processes node. These variables will contain the

settings required to connect to ABBYY FlexiCapture. These settings will be used by the processes.
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Configuring and starting the components

Before you start configuring the Multi-Task Package components, make sure that the .bprelease file has

been successfully imported and the ABBYY FlexiCapture project has been configured.

To configure the processes in Blue Prism:

1. In Blue Prism, open the System tab and expand the Environmental Variables group in the

Processes node. For the values of the variables, specify the settings required to connect to

ABBYY FlexiCapture and click Apply.

2. Open the Studio tab and expand the FlexiCapture 12 Processes group in the Processes node

to see the imported sample processes.

3. Open the Batch Sender process and then open the properties of the InputDirPath data item. In

Initial Value, specify the path to the folder from which the process should pick up files to be sent

to ABBYY FlexiCapture. Save the changes.

4. Place the images to be processed into the folder you specified in step 3 above.

5. Open the Batch Fetcher process and then open the properties of the OutputDir data item. In

Initial Value, specify the path to the folder where the process should save processing results.

Save the changes.
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To start the processes in Blue Prism:

1. Open the Control tab. In the Available Processes pane, find the processes used by ABBYY

FlexiCapture. Additionally, make sure that there is a resource with the "Yes - Connected" status in

the Resources pane.

2. Using drag-and-drop, assign the Batch Monitor and Batch Fetcher processes to the connected

resource. The processes will appear in the Environment window, with "Pending" indicated in the

Status column.

3. Select the above processes, right-click them, and select Start on the shortcut menu. The

processes will run in the background, checking items in the MonitorQueue and FetcherQueue

queues.
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4. Repeat the steps above to start the Batch Sender process. This process will pick up files from

the input folder, send them to ABBYY FlexiCapture and write the ID of the newly created batch to

the MonitorQueue queue.

5. Wait until the Batch Monitor process has checked the status of the batch. If the batch has been

processed successfully, the Batch Monitor process will add its ID to the FetcherQueue queue.

Next, the Batch Fetcher process will place the files containing the processing results into the

output folder. If the batch ends up in the "Verification" stage, the Batch Monitor process will add

its ID into the VerifierQueue queue. If this is the case, start the Batch Verifier process to verify

the batch on the Web Verification Station.

Usage scenarios

The ABBYY FlexiCapture Multi-Task Package for Blue Prism can typically be used in the following

scenarios:

· ABBYY FlexiCapture as unattended service.

· ABBYY FlexiCapture as attended service.
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ABBYY FlexiCapture as an unattended service

In this scenario, ABBYY FlexiCapture processes documents without human assistance and recognition

results are not verified by human operators.

At least one instance of the Batch Monitor and Batch Fetcher processes is constantly running, and

the Sender process sends files to ABBYY FlexiCapture for processing.

The MonitorQueue queue is used for transferring batch IDs between the Batch Sender and Batch

Monitor processes, and the FetcherQueue queue is used for transferring batch IDs between the

Batch Monitor and Batch Fetcher processes.
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ABBYY FlexiCapture as an attended service

In this scenario, a human operator verifies documents on the Web Verification Station.

This scenario extends the "ABBYY FlexiCapture as unattended service" scenario with a Batch Verifier

process and a VerifierQueue queue.

Configuring your ABBYY FlexiCapture project

In ABBYY FlexiCapture, documents are processed within projects. ABBYY FlexiCapture will identify the

type of each document and apply the appropriate Document Definition that has been prepared

specifically for that type. Each Document Definition includes one or more export profiles to be used for

exporting document images and data. If you are not familiar with the aforementioned concepts, please

refer to the ABBYY FlexiCapture documentation, where you will find a detailed description of the capture

process. To set up the export of data from ABBYY FlexiCapture, you will need to create a new script

export profile in your ABBYY FlexiCapture project.

Before you start configuring your project, please make sure that you have the following software

installed:

· ABBYY FlexiCapture 12 Project Setup Station (required if you are using ABBYY FlexiCapture

Distributed Edition or ABBYY FlexiCapture Cloud).

If you already have an ABBYY FlexiCapture project for which you need to set up data export to Blue

Prism, open that project. Otherwise, you will need to create a project. You can also upload to the server

the preconfigured project that ships with the distribution package. You can find this project in ABBYY

FlexiCapture Connector for BluePrism\Multi-Task Package\FlexiCapture Sample Projects.

Launch the Project Setup Station and in the Open Project dialog box click:

http://help.abbyy.com/
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· Create New... to create a new project.

· Browse... to open an existing project stored on your local drive.

· Browse from Server...  to a open a project that you earlier uploaded to the ABBYY FlexiCapture

Application Server.

Next, you need to upload the project on to the ABBYY FlexiCapture Application Server:

1. Click File → Upload Project to Server....

2. In the Upload Project to Application Server dialog box specify the address of the server, the

protocol to be used, and your credentials.

3. If you are using ABBYY FlexiCapture Cloud, complete the URL field, specifying one of the

following three FlexiCapture Cloud instances (you should specify the instance that your company

is registered in):

· https://europe.flexicapture.com

· https://australia.flexicapture.com

· https://usa.flexicapture.com

4. In the Tenant name field specify the name of your company, select the Use server

authentication option, and enter your credentials.

5. Click Test Connection to check that you have entered the correct data.

6. Click OK to upload project to Application Server.
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Note: When uploading a project to the cloud or when opening a project from the cloud, the following
error may occur: "Application server version is not compatible." If you see this error, the version of your
Project Setup Station does not match the version of the cloud-based Application Server. To obtain a
compatible version of ABBYY FlexiCapture, please contact the ABBYY sales office servicing your region
(see https://www.abbyy.com/contacts).

7. When you see the "Operation completed" message, click Close. In the next dialog box, click Yes

to open the uploaded project from the server.

Now you need to configure your project, i.e. to create an export profile in your Document Definition and

to select the appropriate type of workflow.

Creating an export profile

To configure an export profile:

1. In the ABBYY FlexiCapture Project Setup Station click Project → Document Definitions... to

open the list of Document Definitions available for the project. Select the Document Definition for

which you want to specify new export settings, and click Edit....

2. Click Document Definition → Export Settings....

3. Click the Add... button to start the export profile creation wizard.

https://www.abbyy.com/contacts
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4. In the Select the Type of Destination step, select Export to data files from the Type drop-

down list, select the Critical option below, select the Errors are irrelevant item from the

Document condition drop-down list, and click Next.

5. In the Export Data to Files step, make sure the Export path field is empty and specify a file

name template. Click Next.
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6. In the Data File Format step, select the required output format in the File type field, and click

Next.

7. Provide a name for your newly created export profile and click Finish.

8.  In the Export Settings dialog box, check the Enabled box for the newly created export profile.

Click Apply, then click OK.

9. Save and close the Document Definition editor. Next, click the Publish button to publish your

Document Definition.

Configuring an ABBYY FlexiCapture workflow

To configure an  ABBYY FlexiCapture workflow:

1. Click Project → Project Properties... and make sure that the Export root path on the General

tab is left empty.

2. Open the Workflow tab. Depending on your usage scenario, select the appropriate workflow type:

§ If you intend to process documents in unattended mode, select Unattended from the Schema

drop-down list and click OK.

§ If you need recognition results to be verified prior to export, select Advanced from the Schema

drop-down list. Next select Verification and click the Edit… button. In the Workflow Stage

Properties dialog box, select Wait for all documents of a batch and Enable web stations.
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Single-Task Package
Architecture

The ABBYY FlexiCapture 12 single-task integration solution for Blue Prism comprises the following three

components:

· FlexiCapture 12 VBO, a business object that operates on the Blue Prism side. This object sends

data to ABBYY FlexiCapture 12 and receives results in synchronous mode.
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· FlexiCapture 12 Listener, a web service that operates on the Blue Prism side. This service handles

requests from ABBYY FlexiCapture 12.

· FlexiCapture Export Connector operating on the ABBYY FlexiCapture 12 side. This connector

sends requests to the FlexiCapture 12 Listener web service at the export stage.

Usage scenarios

The ABBYY FlexiCapture single-task integration solution for Blue Prism can typically be used in the

following three scenarios.

1. FlexiCapture as an unattended service: files are sent synchronously from Blue Prism to

ABBYY FlexiCapture 12; no verification is required

The FlexiCapture 12 VBO component, which runs on the Blue Prism side, sends a file to ABBYY

FlexiCapture 12 and gets back extracted fields and exported files. In this scenario, files received by

ABBYY FlexiCapture 12 do not require verification, so once the recognition is completed, they go directly

to the export stage.

Note: The ABBYY FlexiCapture operator must have the role of Scanning Operator or Administrator
for the given project and batch type. These roles are granted by the administrator in the Administration
and Monitoring Console.

2. FlexiCapture as input: files and data are sent synchronously from ABBYY FlexiCapture 12 to

Blue Prism

The FlexiCapture Export Connector is used at the export stage in ABBYY FlexiCapture 12 according to a

script export profile. The connector sends files and extracted fields to the FlexiCapture 12 Listener web

service. ABBYY FlexiCapture 12 may receive image files from the Scanning Station or FlexiCapture

Mobile Client, for example.
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3. FlexiCapture as an attended service: files are sent asynchronously from Blue Prism to

ABBYY FlexiCapture 12; verification is required

The FlexiCapture 12 VBO, which runs on the Blue Prism side, sends a file to ABBYY FlexiCapture 12

and gets back a URL linking to a document verification page on the Web Verification Station. The user

clicks the link and verifies the document. Once the verification is completed, a script export profile is

applied on the ABBYY FlexiCapture 12 side, which makes the FlexiCapture Export Connector send the

files and extracted field data to the FlexiCapture 12 Listener web service.

Note: The ABBYY FlexiCapture operator must either have the roles of Scanning Operator (to send
documents) and Verification Operator (to receive a URL linking to the document verification page on the
Web Verification Station) for the given project and batch type, or the role of Administrator.
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ABBYY FlexiCapture as an unattended service

To configure this scenario, complete the following steps:

1. On the Blue Prism side, install and configure the FlexiCapture 12 VBO.

2. To enable the FlexiCapture 12 VBO to receive information about the extracted fields on the Blue

Prism side, the standard XML export profile (Export to data files) must be configured in the

Document Definition. 

Note: If, besides export to XML, other standard export profiles are configured in ABBYY FlexiCapture to
export data into other file formats, files in these formats will also be sent back to the FlexiCapture 12
VBO.

3. On the ABBYY FlexiCapture side, click Batch Type Properties → Workflow tab (or Project →

Project properties for the "Default" batch type) and select the Unattended schema.

For a sample ABBYY FlexiCapture project configured for this scenario, see the "Sample FlexiCapture

project" section.

Sample FlexiCapture project

The ABBYY FlexiCapture single-task integration solution for Blue Prism is shipped with a preconfigured

ABBYY FlexiCapture project with test images.

This example demonstrates how documents can be processed in the scenario that does not require

verification (using the Unattended service batch type). 

For the batch type used in this example, the Unattended processing schema is selected on the

Workflow tab of the Batch Type Properties dialog box. At the export stage, only the XML export profile

is applied.

To run the "Unattended processing" example:

1. Open the sample project on the ABBYY FlexiCapture Project Setup Station and then upload it to

the ABBYY FlexiCapture Application Server.

2. In Blue Prism, install BPA Object - FlexiCapture 12 VBO.xml together with the BPA Process -

FlexiCapture 12 Processor.xml usage example.

3. In the FlexiCapture 12 Processor example, specify the following:

· InputFilePath – the path to the file (including the file name) to be sent to ABBYY FlexiCapture

12

· OutputDir – the folder where the processing results are to be saved

· ServerUrl – the address of the ABBYY FlexiCapture 12 server

· Company - the name of the ABBYY FlexiCapture tenant, if you are working with a tenant

· Username and Password – the credentials of the user's  ABBYY FlexiCapture account

Note: Make sure that the user has the role of Scanning Operator for this project and batch type, or the
role of Administrator.
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· ProjectName – the name of the project on the server (specify "InvoiceDemoProject")

· BatchType – the name of the batch type (specify "Unattended service")

4. In Blue Prism, start the FlexiCapture 12 Processor process.

The image file will be sent to ABBYY FlexiCapture 12, where it will be processed, and the processing

results will be immediately sent back to Blue Prism. The processing results in this example will include

the original image file, an XML document, and fields and their data, which Blue Prism will write into a text

document it creates.

ABBYY FlexiCapture as input

To configure this scenario, complete the following steps:

1. On the Blue Prism side, install and configure the FlexiCapture 12 Listener process.

2. On the ABBYY FlexiCapture side, create a script export profile in the Document Definition.

ABBYY FlexiCapture as an attended service

When ABBYY FlexiCapture receives a document from Blue Prism, the document may go to the

verification stage or skip that stage and go directly to the export stage, depending on whether the

extracted data require verification or not.

If the extracted data do not require verification, the document goes to the export stage in ABBYY

FlexiCapture and the export results are then sent to Blue Prism. In this case, the sending and receiving

is done by means of the ABBYY FlexiCapture Web API.

If the extracted data require verification, Blue Prism will receive the processing results asynchronously.

First, the ABBYY FlexiCapture 12 VBO will send the data to ABBYY FlexiCapture via the Web API and

get a link to a document verification task on the Web Verification Station. Once the data are verified, they

are sent to the ABBYY FlexiCapture 12 Listener service on the Blue Prism side.

Depending on whether you need to skip verification and send files and extracted data to the ABBYY

FlexiCapture 12 VBO or to perform verification and send files and data to the Blue Prism Listener web

service, you need to configure the workflow in ABBYY FlexiCapture accordingly.

To send results, such as fields and extracted field data, from ABBYY FlexiCapture to the ABBYY

FlexiCapture VBO, you need to configure the standard XML export profile. Additionally, you need to

configure the script export profile so that it is applied only to documents that have gone through the

verification stage.

To configure this scenario, complete the following steps:

1. On the Blue Prism side:

a. Install and configure the FlexiCapture 12 VBO.

b. Install and configure the FlexiCapture 12 Listener process.

2. On the ABBYY FlexiCapture side:

a. Create a script export profile in the Document Definition and modify the script.

b. Create Standard XML export profile.
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c. Configure the ABBYY FlexiCapture workflow.

Modifying the script export profile

The profile will be applied to documents that have gone through the verification stage. To configure both

unattended and attended processing for the same Document Definition, you must first create a script

export profile and then modify this profile as described below:

1. In the Export Settings dialog box, click the Edit... button to modify an export script. 

2. Click the Edit Script... button and add the following code into the script editor:

using Abbyy.Connectors.Dms.ComFacade;

using Abbyy.Infrastructure.Logging;

using System.Collections.Generic;

if (Document.Properties.Has("WasVerified")

    && Document.Properties.Get("WasVerified") == bool.TrueString)

{

    // TODO: Place the main code of your export script inside these braces.

    // 

    // Factory factory = new Factory();

    // . . .

}

This script will check documents for the "WasVerified" registration parameter, which indicates whether

or not the document has gone through the verification stage, and consequently, whether or not the user

expects to receive verified data.

Once you have modified the script, you need to save and publish the modified Document Definition. To

do this, close the Document Definition editor and click the Publish button.

Note: If documents are being processed within the project at the time when you add a new export
profile or edit an existing export profile, update them to the latest version by pressing Alt+Shift+U or by
selecting Update to Latest Version from their shortcut menu.

Configuring the ABBYY FlexiCapture workflow

The ABBYY FlexiCapture workflow can be configured either for each batch type separately or for the

"Default" batch type. To configure the workflow:

1. On the Project Setup Station, either click Project → Project Properties… (if you want to

configure the "Default" batch type) or click Project → Batch types → Edit... (if you want to

configure a particular batch type).

2. On the Workflow tab of the Project Name Properties dialog box, change the workflow schema

from Simple to Advanced.
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3. On the same tab, select the verification stage and click the Edit.... button to open the Workflow

Stage Properties dialog box and on the General tab, select the Enable web stations option.

Click OK to save the changes.

4. Return to the Workflow tab in the Project Name Properties dialog box and click the Stage...

button to add a new stage. In the Create Processing Stage dialog box, select Automatic and

click OK.

5. In the Workflow Stage Properties dialog box, provide a name for the new stage, make sure that

the Wait for all documents of a batch option is selected, and select the Linked to previous

option.

6. On the Script tab, select Document processing from the Type drop-down list.

7. On the same tab, click the Edit script… button and type in the following script code:

Document.Properties.Set("WasVerified", bool.TrueString);

This script adds a registration parameter to each processed document that indicates whether or

not the given document has gone through the verification stage.

8. On the Entry Conditions tab, select Under these conditions and click the Rule... button to

specify a condition when documents should be sent to the newly created stage.

9. In the Rule Settings dialog box, provide a name for the new rule in the Name field. Then from the

Condition type drop-down list, select Script, click the Script… button and type in the following

script code:
Result.CheckSucceeded = (Document.StageInfo.StageName == "Verification Postprocessing" ||

Document.StageInfo.StageName == "Verification");

This script sets the input condition for the new stage: If a document arrives from the verification

stage, it will be admitted into the new stage and will be provided with a "WasVerified" registration

parameter. 

10.Save the newly configured rule and the new script stage. 

Important! The new script stage must immediately follow the verification stage.

For a sample ABBYY FlexiCapture project configured for this scenario, see the "Sample FlexiCapture

project" section.

Sample FlexiCapture project

The ABBYY FlexiCapture single-task integration solution for Blue Prism is shipped with a preconfigured

ABBYY FlexiCapture project with test images.

This example demonstrates how documents can be processed in the scenario that requires verification

(using the Attended service batch type). 

To run the "Attended processing" example:

1. Open the sample project on the ABBYY FlexiCapture Project Setup Station and then upload it to

the ABBYY FlexiCapture Application Server.

2. In Blue Prism, install BPA Object - FlexiCapture 12 VBO.xml together with the BPA Process -

FlexiCapture 12 Processor.xml usage example. 

3. Install BPA Process - FlexiCapture 12 Listener.xml.
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4. Open the properties dialog box for the Document Definition named European Invoice, click the

Export Destinations tab, select the Export_to_BluePrism export profile, and click the Edit...

button. Then click Edit script and in the code of the script, specify the actual values required to

connect to the FlexiCapture12Listener web service in Blue Prism:

· connectorSettings.DmsConnectionSettings.Server = "web-service-address";

· connectorSettings.DmsConnectionSettings.Credentials.Username = "username";

· connectorSettings.DmsConnectionSettings.Credentials.Password = "password";

5. In the FlexiCapture 12 Processor example, specify the following:

· InputFilePath – the path to the file (including the file name) to be sent to ABBYY FlexiCapture

12

· OutputDir – the folder where the processing results are to be saved

· ServerUrl – the address of the ABBYY FlexiCapture 12 server

· Company – the name of the tenant, if the project has been uploaded to a tenant on the

FlexiCapture Application Server (if you are working with ABBYY FlexiCapture Cloud, specify the

name of your company here)

· Username and Password – the credentials of the user's  ABBYY FlexiCapture account

Note: Make sure that the user has the roles of  Scanning Operator and Verification Operator for this
project and batch type, or the role of Administrator.

· ProjectName – the name of the project on the server (specify "InvoiceDemoProject")

· BatchType – the name of the batch type (specify "Attended service")

6. In Blue Prism, start the FlexiCapture 12 Processor process.

The image file will be sent to ABBYY FlexiCapture 12 and, if the document does not require verification,

the standard XML export profile will be applied at the export stage and the export results will be

immediately sent back to Blue Prism. If, on the other hand, the document is sent to the verification

stage, a link to a document verification task on the Web Verification Station will be sent to the ABBYY

FlexiCapture 12 VBO. Once the document is verified, the script export profile will be applied at the export

stage, which will send the data to the ABBYY FlexiCapture 12 Listener. The processing results in this

example will include the original image file and a text file containing the fields and extracted field data.

Installing, configuring, and starting the components

ABBYY FlexiCapture 12 VBO

ABBYY FlexiCapture 12 Listener process

FlexiCapture Export Connector

ABBYY FlexiCapture 12 VBO

The ABBYY FlexiCapture 12 VBO component appears as a business object to Blue Prism. This object

sends files to ABBYY FlexiCapture 12 and gets back the processing results. 
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Important! Before sending image files from Blue Prism to ABBYY FlexiCapture using the ABBYY
FlexiCapture 12 VBO, you must separate the documents into files (one file per document).

The ABBYY FlexiCapture 12 VBO ships with a sample process named BPA Process - FlexiCapture

12 Processor.xml that accesses the VBO.

The ABBYY FlexiCapture 12 VBO comprises the following components:

Component Description

BPA Object - FlexiCapture 12 VBO.xml A business object that submits files to ABBYY

FlexiCapture 12 and gets back the processing

results.

BPA Process - FlexiCapture 12 Processor.xml An example of using the ABBYY FlexiCapture 12

VBO.

Installing the ABBYY FlexiCapture 12 VBO

To make the ABBYY FlexiCapture 12 VBO and its usage example available on the Blue Prism side, you

need to import the BPA Object - FlexiCapture 12 VBO.xml and BPA Process - FlexiCapture 12

Processor.xml files into Blue Prism. To do this:

1. Open Blue Prism and on the File menu, click Import.

2. Prompted by the on-screen instructions, select the following files to import, one by one:

· BPA Object - FlexiCapture 12 VBO.xml

· BPA Process - FlexiCapture 12 Processor.xml

· Additional objects required to run the FlexiCapture 12 VBO usage example (their default

location is C:\Program Files\Blue Prism Limited\Blue Prism Automate\VBO):

o BPA Object - Utility - File Management.xml

A business object for working with files stored on the local hard drive.

o BPA Object - Utility - Environment.xml

A business object for interacting with the environment (e.g. for running third-party

processes, such as a web browser).

3. Once the import is complete, all the business objects and the usage example will be displayed in

Blue Prism on the Studio tab.

4. Restart Blue Prism for the changes to take effect.

Configuring the ABBYY FlexiCapture 12 VBO

Before you can start using the ABBYY FlexiCapture 12 VBO, you need to create a new process in Blue

Prism:

1. On the Studio tab, right-click Processes and then click the Create Process command on the

shortcut menu.
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2. In the workspace, create an element of type Action. Then double-click to open the added activity.

3. In the window that opens, specify the following:

· Name: <name of activity>.

· Business Object: FlexiCapture 12 VBO.

· Action: Process.

· On the Inputs tab, specify the following input data elements:

o ServerUrl – the address of the ABBYY FlexiCapture server in the following format:

http://<ApplicationServer>

o Company - the name of the ABBYY FlexiCapture tenant (if you are working with ABBYY

FlexiCapture Cloud, specify the name of your company here)

Note: If you are not working with a tenant, leave this field empty.

o Username – the name of the ABBYY FlexiCapture user

o Password – the password of the ABBYY FlexiCapture user

o ProjectName – the name of the project on the ABBYY FlexiCapture server

o BatchType – the name of the batch type that will be assigned to the batch created in

ABBYY FlexiCapture for processing the file

o FileName – the name of the input file

o FileContent – the file to be sent to ABBYY FlexiCapture (must be stored in a data item of

binary data type)

o BatchRegistrationParameters – a collection of objects with "Name" and "Value" text fields

(these objects will be transformed into batch registration parameters on the ABBYY

FlexiCapture side, which can be used, for example, for naming export files)

Note: You can have these elements created automatically by clicking the icon on the left of the value in
the Store In column.

· On the Outputs tab, specify the output data elements that will store the results of the

FlexiCapture 12 VBO Process method:

o DocumentDefinition – the name of the Document Definition that was applied to the input

image by ABBYY FlexiCapture

o Fields – a collection of objects with "Name" and "Value" text fields for storing the names

and extracted values of fields

o Files – a collection of objects with a "Name" text field and a "Content" binary field for storing

exported image files and their names

o VerificationUrl – a text field that stores the URL of the document verification page

Note: Windows authentication will be used to access the URL, which will be returned to the ABBYY
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FlexiCapture 12 VBO.

Note: When a batch is created, the ABBYY FlexiCapture 12 VBO adds a
FileNameWithoutExtension registration parameter to the batch. This registration parameter will store
the name of the input file without the file extension. If the BatchRegistrationParameters input list of
registration parameters already includes a FileNameWithoutExtension parameter, the value from
BatchRegistrationParameters will be passed as the name of the input file to the batch parameters.

Once the activity is configured, the elements of the specified types will appear in the workspace. Data

received from ABBYY FlexiCapture 12 will be recorded in these elements.

Starting the ABBYY FlexiCapture 12 VBO

To start the configured ABBYY FlexiCapture 12 VBO, click the Go button on the Blue Prism toolbar. 

If all the settings are correct, Blue Prism will receive processing results from ABBYY FlexiCapture 12

(the format of the results will depend on the usage scenario). These results will be stored in the output

data elements you created when configuring the VBO. 

If any of the configuration settings is invalid (e.g. if an incorrect ABBYY FlexiCapture 12 address is

specified), an error message will be displayed.

ABBYY FlexiCapture 12 Listener process

The ABBYY FlexiCapture 12 Listener process is deployed on the Blue Prism side. The listener receives

SOAP requests sent by the FlexiCapture Export Connector. It is assumed that the user will import the

ABBYY FlexiCapture 12 Listener into Blue Prism and modify it to suit his needs.

Important! To execute the FlexiCapture 12 Listener process, the machine with Blue Prism that will
receive exported files and data must be running as a Resource PC. To make sure that your Blue Prism
machine is running as a Resource PC, start Blue Prism, click the Control tab, and make sure that the
machine is displayed as "connected" in the Resources window. If this is not the case, open the
command line prompt and execute the following command:
"C:\Program Files\Blue Prism Limited\Blue Prism Automate\Automate.exe" /resourcepc /public

A window named "Blue Prism - Resource PC (Port 8181)" will open where you will see logs for your
Resource PC. Click Hide to minimize this window.

The ABBYY FlexiCapture 12 Listener process comprises the following one file:

Component Description

BPA Process - FlexiCapture 12 Listener.xml A process that accepts and processes SOAP

requests sent by the FlexiCapture Export

Connector.

Installing the ABBYY FlexiCapture 12 Listener

To make the FlexiCapture 12 Listener process available on the Blue Prism, you need to import the BPA

Process - FlexiCapture 12 Listener.xml file into Blue Prism and expose the resulting process as a

web service. To do this:

1. Open Blue Prism and on the File menu, click Import.

2. Prompted by the on-screen instructions, select the following files to import, one by one:

· BPA Process - FlexiCapture 12 Listener.xml
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· Additional object required to run the ABBYY FlexiCapture 12 Listener usage example (its

default location is C:\Program Files\Blue Prism Limited\Blue Prism Automate\VBO):

o BPA Object - Utility - File Management.xml

A business object for working with files stored on the local hard drive.

Note: The FlexiCapture 12 Listener usage example already includes a request processing example.
The user can freely modify this example with the exception of the parameters that have to be accepted
on the Start block (see below).

3. Once the import is complete, all the business objects and the usage example will be displayed in

Blue Prism on the Studio tab.

4. On the System tab, expand the Processes node and click Exposure. Then in the top right corner

of the Process - Exposure window, click the Expose a Process link.

5. In the Expose Process dialog box, select FlexiCapture 12 Listener and click Next.

6. In the next dialog box, make sure that FlexiCapture12Listener is specified as the exposed name

of the process and click Finish.

The process will appear in the list of exposed processes. To make sure that the process has been

exposed as a web service, open the following link on the computer running Blue Prism: 

http://localhost:8181/ws/FlexiCapture12Listener?wsdl. If all the settings are correct, you will see a

WSDL file with a description of the web service.

Configuring the ABBYY FlexiCapture 12 Listener process

Before you can start using the FlexiCapture 12 Listener process, you need to configure the following

settings in Blue Prism:

1. On the Studio tab, double-click the name of the process to open the process editor.

2. By default, the FlexiCapture 12 Listener process saves received files and fields to the output

folder, where it creates a subfolder with results for each exported document. You can specify an

output folder in the data item named "RootDir."

The user can freely modify this process with the exception of the process name and the set of

input parameters.

The input parameters, their names, and data types must match those in requests sent by the

FlexiCapture Export Connector. Open the properties of the very first element of the "Start" process and

specify data items and their values in the "Store In" column:

· DocumentDefinition – the name of the Document Definition that was applied to the input image

by ABBYY FlexiCapture (must be stored as the "Text" data type)

· Fields – a collection of objects with "Name" and "Value" text fields for storing the names and

extracted values of fields

· Files – a collection of objects with a "Name" text field and a "Content" binary field for storing

exported image files and their names

http://localhost:8181/ws/FlexiCapture12Listener?wsdl
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· BatchRegistrationParameters – a collection of objects with "Name" and "Value" text fields

(contains the names and values of the batch registration parameters)

Starting the ABBYY FlexiCapture 12 Listener process

The ABBYY FlexiCapture 12 Listener process exposed as a web service is started by a SOAP request

sent during document export from the ABBYY FlexiCapture server to the address of the web service.

FlexiCapture Export Connector

The FlexiCapture Export Connector is a set of libraries running on the ABBYY FlexiCapture 12 side. The

purpose of these libraries is to export processing results from ABBYY FlexiCapture to Blue Prism.

The FlexiCapture Export Connector:

Component Description

DmsConnector.dll An assembly of models and abstractions common

to different types of connectors.

AfcDmsConnector.dll This library receives as input objects specific to

ABBYY FlexiCapture, converts them into an

internal representation, and sends the converted

result to Blue Prism.

BluePrismConnector.dll This library contains the connector for Blue Prism.

This library sends processing results from ABBYY

FlexiCapture to the ABBYY FlexiCapture 12

Listener web service. 

Adding the assemblies to a Document Definition

Before you can configure document export, you must add the assemblies to your ABBYY FlexiCapture

project. To add the assemblies, complete the following steps:

1. Open the project in the ABBYY FlexiCapture Project Setup Station.

Note: To open a project from ABBYY FlexiCapture Cloud, select the Open Project from Server…
command. In the Application Server URL field, specify the address in the following format:
https://europe.flexicapture.com#CompanyName, where CompanyName is the name of your company.

2. Click Project → Document Definitions... to open the list of Document Definitions available for

the project, select the Document Definition for which you want to specify new export settings, and

click Edit....

3. Click Document Definition → Document Definition Properties... to open the properties of the

Document Definition and then click the .Net References tab.

4. Click the Add... button on the .Net References tab. In the Add Assembly dialog box, select

Attached file from the Type drop-down list, and in the Reference field, specify the path to the

DLL file that you wish to add. Repeat this step for the AfcDmsConnector.dll,

DmsConnector.dll, and BluePrismConnector.dll.
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ABBYY FlexiCapture export profiles

ABBYY FlexiCapture exports data based on the export profiles in the Document Definitions. To configure

a usage scenario, you need to set up the corresponding export profile. There are two types of export

profile:

1. Standard XML export profile

2. Script export profile. For details, please see:

· Creating an export profile

· Using a script to specify export settings

· Using an XML file to specify export settings

· Configuration file fields

Standard XML export profile

This profile is used by the ABBYY FlexiCapture 12 VBO to receive image files and extracted field data.

The profile is applied to documents that have not gone through the verification stage.

To configure the standard XML export profile:

1. Open the ABBYY FlexiCapture Project Setup Station and open the project.

2. Click Project → Document Definitions... to open the list of Document Definitions available for

the project. Select the Document Definition for which you want to specify new export settings, and

click Edit....

3. Click Document Definition → Export Settings... and click the Export Destinations tab.

4. Click the Add... button to start the export profile creation wizard.

5. In the Select the Type of Destination step, select Export to data files from the Type drop-

down list, select the Save document images option, and click Next.

6. In the Export Data to Files step, make sure the Export path field is empty and click Next.

7. In the Data File Format step, select XML Document (*.xml) in the File type field and click Next.

8. In the Export Images to Files step, select the Save images with data and click Next.

9. In the Image File Format step, select the desired image file format options and click Next.

10.Provide a name for your newly created export profile and click Finish.

11.In the Export Settings dialog box, check the Enabled box for the newly created export profile.

12.Open the <Project Name> Properties (Project → Project Properties...) dialog box and make

sure that the Export root path on the General tab is left empty. This means that the export

profile will send data to Blue Prism.
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Creating a script export profile

To be able to export data from  ABBYY FlexiCapture to Blue Prism via a web service, you need to

configure a script export profile in the Document Definition.

To create an export profile for Blue Prism:

1. On the Project Setup Station open your ABBYY FlexiCapture project.

Note: Make sure that all the necessary assemblies are added to the Document Definition.

2. Click Project → Document Definitions... to open the list of Document Definitions available for

the project, select the Document Definition for which you want to specify new export settings, and

click Edit....

3. Click Document Definition → Export Settings....

4. Click the Add... button to start the export profile creation wizard.

5. In the Select the Type of Destination step, select Custom export (script) from the Type drop-

down list and then select Errors are irrelevant in the Document condition field. Leave the other

settings unchanged or modify them as described in ABBYY FlexiCapture Help.

6. In the Script Export step, click the Edit Script... button, select C# .Net script language, and

paste into the script editor one of the two sample scripts provided in the connector files: 

BluePrism - ExportScript - Configure by script.cs or BluePrism - ExportScript - Configure

by XML.cs. For detailed instructions on using each of these scripts, see Using a script to specify

export settings and Using an XML file to specify export settings below. You can always edit this

script later, but for the moment, save the changes and close the script editor. Detailed

instructions for setting up your export script will be provided below.

7. In the Select the Destination Name step, specify a name for your export profile and click Finish.

8. The newly created export profile will appear in the list of available export profiles in the export

settings dialog box. To make ABBYY FlexiCapture use this profile on Export stage, select the box

next to the profile in the Enabled column.

9. Click OK, then save and close the Document Definition editor. Next, click the Publish button to

publish your Document Definition.

Note: If documents are being processed within the project at the time when you add your new export
profile, update them to the latest version by pressing Alt+Shift+U or by selecting Update to Latest
Version from their shortcut menu.

Once the processing is completed, the document and its metadata are sent from the export stage to

Blue Prism via the ABBYY FlexiCapture 12 Listener web service. The export process is logged in the

Task Log on the Processing Server. 

Note: The event logs are also available on the Processing Monitor tab of the Administration and
Monitoring Console.

When the export completes successfully, the ABBYY FlexiCapture 12 Listener web service will save the

export results on the Blue Prism server in the file format specified by the user.

http://help.abbyy.com/en-us/flexicapture/12/standalone_administrator/export_main
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Using a script to specify export settings

One advantage of using a script is that all the export settings will be automatically used by all the ABBYY

FlexiCapture stations from which data are exported to Blue Prism. When using an XML file, you can only

specify static settings, whereas scripts allow you to specify different file naming rules, file locations, and

field mappings depending on the data contained in the exported document.

When working with ABBYY FlexiCapture Cloud, you also need to use a script to specify export settings,

since ABBYY FlexiCapture Cloud does not provide the ability to store an XML file with configuration on

processing stations.

However, to modify the export settings, you will have to make changes to the script and, consequently,

publish a new version of the Document Definition.

Please use the script named BluePrism - ExportScript - Configure by script.cs from the connector

files.

Using an XML file to specify export settings

One advantage of using an XML file is that you don’t have to edit the script code or the Document

Definition. All modifications can be made by editing the XML file, which is much simpler than editing the

script code. However, the XML file should be located on every ABBYY FlexiCapture processing station.

And you will also have to synchronize it manually on all of the ABBYY FlexiCapture stations from which

data is to be exported to Blue Prism.

To specify export settings in an XML file:

1. As your export script, use the BluePrism - ExportScript - Configure by XML.cs file from the

\ABBYY FlexiCapture Connector for BluePrism\Single-Task

Package\Samples\FlexiCapture Scripts files.

2. Create an XML file named <Project name>_<Document Definition name>.xml. This naming

scheme will allow you to have multiple XML files for different Document Definitions.

3. In the registry of the computer with a processing station, locate

HKEY_LOCAL_MACHINE\SOFTWARE\ABBYY\FlexiCapture\12.0\Connectors\BluePrism and in

its "XmlFolder" string value field, specify the path to the folder where the settings file is to be

stored.

4. In the registry of the computer with a processing station, locate the

HKEY_LOCAL_MACHINE\SOFTWARE\ABBYY\FlexiCapture\12.0\Connectors\ and set its

"BluePrism" string value field to true.

Note: If you do not have the necessary keys in the HKEY_LOCAL_MACHINE \ SOFTWARE registry
branch, create them.

Note: In the code of BluePrism - ExportScript - Configure by XML.cs, you can also find some other
possible naming schemes for your XML files.

Configuration file fields

This section describes the fields of the BluePrism - ExportScript - Configure by script.cs and

BluePrism - ExportScript - Configure by XML.cs configuration file.
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Server contains the address of the server where the ABBYY FlexiCapture 12 Listener web service is

located: <Server>http://BluePrism:8181/ws/FlexiCapture12Listener</Server>.

Username contains the name of the user in Blue Prism. For example, <Username>username</Username>.

Password contains the Blue Prism user's password. For example, <Password>password</Password>.

FileName contains the file name template for the document sent to the web service. For example,

<FileName>&lt;Batch&gt;</FileName>.

Note: The name of the document may have an unchanging static part and a changing dynamic part.
The dynamic part is defined by tags, which are replaced by the ABBYY FlexiCapture document property
values at the time of export. Each tag must be enclosed in angle brackets. In the XML file:

· ‘&lt;’ stands for ‘<’;

· ‘&gt;’ stands for ‘>’.

Possible tags for the dynamic part of the name:

· Project for the name of the project in ABBYY FlexiCapture;

· Batch for the name of the batch;

· DocumentDefinition for the name of the Document Definition in ABBYY FlexiCapture;

· SourceFile for the name of the source file;

· Identifier for the document identifier in the batch;

· BatchType for the name of the batch type;

· Time for the current time in yyyy-MM-dd_HH-mm-ss format.

If you use the FlexiCapture 12 VBO to send image files to ABBYY FlexiCapture, the batch created for

processing an image will be assigned a FileNameWithoutExtension registration parameter. This

parameter will receive the value from the FileName input parameter (from the VBO). You can also use

the value of this registration parameter in your script for naming export files as follows:

<FileNameWithoutExtension>. Other custom registration parameters can be used to name files in the

following format: <RegParam:ParamName>. You can also use the values of index fields as follows:

<Index:IndexField>.

Note: These dynamically replaceable tags are case-sensitive and the register of the characters used
in the tags above should be preserved.

The following is an example of a document name with a static part:

<FileName>My_static_prefix_&lt;DocumentDefinition&gt;_&lt;Identifier&gt;and_postfix</FileName>

The following is an example of a document name without a static part:

<FileName>&lt;Project&gt;_&lt;Identifier&gt;</FileName>

FieldPairs contains a collection of field pairs.

If your export settings are stored in an XML file, map the fields as follows:
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<FieldPairs>

 <FieldPair>

   <AfcField>Invoice Layout\InvoiceNumber</AfcField>

   <DmsField>InvoiceNumber</DmsField>

 </FieldPair>

</FieldPairs>

where:

· AfcField is the full path to the FlexiCapture Document Definition field from which data are to be

read at the time of export.

· DmsField is the field Name in the Fields collection in the Blue Prism FlexiCapture 12 Listener

process.

If your export settings are specified in the script (BluePrism - ExportScript - Configure by script.cs),

map the fields as follows:

    { @"Invoice Layout\InvoiceNumber", "InvoiceNumber" },

where the value before the comma is the full path to a field in ABBYY FlexiCapture Document Definition

and the value after the comma is the name of the respective field in the Fields collection in the Blue

Prism FlexiCapture 12 Listener process.

ExportImageSavingOptions contains the image saving options to be used at the time of export, such

as the format of the exported image, its quality, and redacted areas. For a detailed description of the

image saving options, please refer to ABBYY FlexiCapture Developer's Help.

http://help.abbyy.com/en-us/flexicapture/12/developer/iexportimagesavingoptions
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