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About the ABBYY FlexiCapture Connector for

Laserfiche
ABBYY FlexiCapture Connector for Laserfiche enables ABBYY FlexiCapture users to upload data

extracted from documents to the Laserfish Avante or Laserfiche Rio enterprise content management

(ECM) systems and offers a custom activity for Laserfiche Workflow Designer. This activity can be used

for submitting files stored in Laserfiche repositories for processing by ABBYY FlexiCapture and in return

get field values and metadata as templates.

Architecture
The ABBYY FlexiCapture Connector for Laserfiche includes the following components:

· A set of binary files, which should be associated with a FlexiCapture project to enable loading files

and metadata into Laserfiche.

· A custom activity for Laserfiche Workflow Designer, which can be set up to send files from

Laserfiche to ABBYY FlexiCapture.

The connector uses Laserfiche SDK Runtime to load document image files and their metadata into the

Laserfiche data storage system.

System requirements
The ABBYY FlexiCapture Connector for Laserfiche supports:

· ABBYY FlexiCapture 12;

Note:  ABBYY FlexiCapture 11 requires a special version of the ABBYY FlexiCapture Connector for
Laserfiche.

· Laserfiche Avante/Rio 10.2.

The ABBYY FlexiCapture Connector for Laserfiche must be installed on a computer with an ABBYY

FlexiCapture Processing Station or a station from which data will be exported (e.g. Project Setup

Station).

The ABBYY FlexiCapture Connector for Laserfiche requires the following external components:

· Microsoft .NET Framework 4.5 or higher;

· Laserfiche SDK 10.2 Runtime.

Note: Standalone and Distributed licenses allow you to load files from ABBYY FlexiCapture into
Laserfiche. To be able to submit files for processing via ABBYY FlexiCapture, you must own a
Distributed license.

ABBYY FlexiCapture performs high-quality full-text OCR, document classification, field detection and

extraction, and exports document images files into searchable PDFs. If, for some reason, you need

documents to be exported as TIF files (which don't have a text layer), text recognition will be performed

on the Laserfiche side. To enable full-text recognition by Laserfiche, you must install the Laserfiche

OCR with OmniPage component on the Laserfiche server.
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Installation
To be able to install the ABBYY FlexiCapture Connector for Laserfiche, you must have Windows

administrator privileges.

To install the Connector, run the ABBYY FlexiCapture 12 Connector for Laserfiche.exe and follow

the instructions of the setup wizard.

Note: You can uninstall the Connector just like any other software by using the Windows Control
Panel. Click Control Panel → Programs → Programs and Features, select ABBYY FlexiCapture
Connector for Laserfiche, and click Uninstall.

Configuring export of data from ABBYY FlexiCapture

to Laserfiche
Before setting up the ABBYY FlexiCapture Connector for Laserfiche, make sure the following software is

installed:

· ABBYY FlexiCapture 12 Project Setup Station (in the case of ABBYY FlexiCapture Distributed

Edition) or Administrator Station (in the case of ABBYY FlexiCapture Standalone Edition);

· ABBYY FlexiCapture Connector for Laserfiche;

· Laserfiche SDK 10.2 Runtime.

You must also have access rights for Laserfiche Avante/Rio 10.2.

When processing documents, ABBYY FlexiCapture uses projects. A project contains one or more

Document Definitions, which are applied to each document after its type has been determined. Every

Document Definition has one or more export profiles, which determine how document images and data

will be exported. For more details, see the overview of document processing in ABBYY FlexiCapture

Help. 

To export data from ABBYY FlexiCapture 12 to Laserfiche ECM systems, you will need to set up each

Document Definition individually. The setup process consists of the following steps:

· Add the assemblies of the ABBYY FlexiCapture Connector for Laserfiche to your Document

Definition.

· Create an export profile in your Document Definition.

· Specify the address of the Laserfiche server, the name of the repository in which you want to store

data, and the username and password for the Laserfiche account you want to use when exporting

data.

· Specify the format in which you want to save document images.

· Specify the path to the folder in which you want to save document files within the Laserfiche

repository and a file naming rule.

· Map the fields in your Document Definition to a Laserfiche document template.

http://help.abbyy.com/
http://help.abbyy.com/
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Adding the assemblies to a Document Definition

Before you can configure document export, you must add the assemblies to your ABBYY FlexiCapture

project. To add the assemblies, complete the following steps:

1. Open the project in the ABBYY FlexiCapture Project Setup Station on the computer where the

connector is installed.

If you want to use only one Document Definition to export data to Laserfiche ECM systems, complete

steps 2 through 4:

2. Click Project → Document Definitions... to open the list of Document Definitions available for

the project, select the Document Definition for which you want to specify new export settings, and

click Edit....

3. Click Document Definition → Document Definition Properties... to open the properties of the

Document Definition and then click the .Net References tab.

4. Click the Add... button on the .Net References tab. In the Add Assembly dialog box, select

Attached file from the Type drop-down list, and in the Reference field, specify the path to the

DLL file that you wish to add. Repeat this step for the AfcDmsConnector.dll,

DmsConnector.dll, and LaserficheConnector.dll files. These libraries are located in the folder

where you installed the Connector (the default path is C:\Program Files (x86)\ABBYY FlexiCapture

Connector for Laserfiche\Bin).

If you want to use more than one Document Definition to export data to Laserfiche ECM systems,

complete steps 5 through 8 instead of steps 2 through 4:

5. Click the Project Properties... on the Project menu to open the properties of the project, and

then click the .Net References.

6. Click the Add... button to open the Add Assembly dialog box, select Attached file from the Type

drop-down list, and specify the path to one of the Connector libraries. You will need to add

AfcDmsConnector.dll, DmsConnector.dll, and LaserficheConnector.dll. These libraries are

located in the folder where you installed the Connector (the default path is C:\Program Files (x86)

\ABBYY FlexiCapture Connector for Laserfiche\Bin).

7. Open one of the desired Document Definitions in the Document Definition Editor (see step 2),

click Document Definition Properties... on the Document Definition menu to open the

properties of the Document Definition, and then click the .Net References tab. Click the Add...

button to open the Add Assembly dialog box, select Shared assembly from the Type drop-down

list, and then select AfcDmsConnector.dll, DmsConnector.dll, and LaserficheConnector.dll

from the list.

8. Save the Document Definition to apply the changes.

Creating an export profile

ABBYY FlexiCapture exports data based on the export profiles in the Document Definitions.

To create an export profile for Laserfiche:

1. On the Project Setup Station or on the ABBYY FlexiCapture Administrator Station, open your

ABBYY FlexiCapture project.
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Note: Make sure that all the necessary assemblies are added to the Document Definition.

2. Click Project → Document Definitions... to open the list of Document Definitions available for

the project, select the Document Definition for which you want to specify new export settings, and

click Edit....

3. Click Document Definition → Export Settings....

4. Click the Add... button to start the export profile creation wizard.

5. In the Select the Type of Destination step, select Custom export (script) from the Type drop-

down list and then select Errors are irrelevant in the Document condition field. Leave the other

settings unchanged or modify them as described in ABBYY FlexiCapture Help.

6. In the Script Export step, click the Edit Script... button, select C# .Net script language, and

paste into the script editor one of the two sample scripts provided in the Samples subfolder in the

folder where you installed the ABBYY FlexiCapture Connector for Laserfiche (the default path is C:

\Program Files (x86)\ABBYY FlexiCapture Connector for Laserfiche\Samples): Laserfiche —

ExportScript — Configure by script.cs or Configure by XML.cs. For detailed instructions on

using each of these scripts, see Using a script to specify export settings and Using an XML file to

specify export settings below. You can always edit this script later, but for the moment, save the

changes and close the script editor. Detailed instructions for setting up your export script will be

provided below.

7. In the Select the Destination Name step, specify a name for your export profile and click Finish.

Using a script to specify export settings

One advantage of using a script is that all the export settings will be automatically used by all the ABBYY

FlexiCapture stations from which data are exported to Laserfiche. When using an XML file, you can only

specify static settings, whereas scripts allow you to specify different file naming rules, file locations, and

field mappings depending on the data contained in the exported document. An export script also allows

you to get a list of Laserfiche repositories, a list of templates and their fields, and the folder structure.

However, to modify the export settings, you will have to make changes to the script and, consequently,

publish a new version of the Document Definition.

Please use the script named Laserfiche — ExportScript — Configure by script.cs, which you can

find in the Samples folder in the folder where you installed the ABBYY FlexiCapture Connector for

Laserfiche (the default path is C:\Program Files (x86)\ABBYY FlexiCapture Connector for

Laserfiche\Samples).

Using an XML file to specify export settings

One advantage of using an XML file is that you don’t have to edit the script code or the Document

Definition. All modifications can be made by editing the XML file, which is much simpler than editing the

script code. However, the XML file should be located on every ABBYY FlexiCapture processing station.

And you will also have to synchronize it manually on all of the ABBYY FlexiCapture stations from which

data is to be exported to Laserfiche.

To specify export settings in an XML file:

1. As your export script, use the Laserfiche — ExportScript — Configure by XML.cs file.

http://help.abbyy.com/en-us/flexicapture/12/standalone_administrator/export_main
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2. Create an XML file named <Project name>_<Document Definition name>.xml in the Config

folder in the folder where you installed the ABBYY FlexiCapture Connector for Laserfiche (the

default path is C:\Program Files (x86)\ABBYY FlexiCapture Connector for Laserfiche\Config). This

naming scheme will allow you to have multiple XML files for different Document Definitions.

Note: In the code of Laserfiche — ExportScript — Configure by XML.cs, you can also find some
other possible naming schemes and locations for your XML files.

Parameters for connecting to the Laserfiche server

The following parameters must be specified:

· the address of the Laserfiche server;

· the name of the Laserfiche repository to be used;

· the username and password for the Laserfiche account under which documents will be uploaded.

If you leave the username and password empty, the documents will be uploaded using the

Windows user account that is running the uploading process. The account under which the

uploading process runs depends on how it is started: if the upload is started by a Processing

Station, it will run under the same account that is running the Processing Station, and if the upload

was started by a user, the uploading process will run under the account which the user used to log

in to the ABBYY FlexiCapture station where he/she started the upload.

Note: Please be aware that if you use an XML file to specify export settings, the password for the
Laserfiche account will be included in this file for everyone to see. See Using a script to specify export
settings, Using an XML file to specify export settings.

The account must have sufficient privileges allowing users to add new documents to the repository. To

assign such privileges to a user, do the following:

1. Open the Laserfiche Administration Console and log in to the repository using an administrator

account.

2. In the layout pane on the left, navigate to the Users and Groups node and select Repository

Users.

3. From the user list, select a user whose account details are used to export documents and open

the account properties.

4. In the General tab, make sure that the Only allow read-only access (Manage Trustees

privilege bypasses this setting) checkbox is not checked.
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5. If the user is assigned to a group, open the settings for that group and make sure that the Only

allow read-only access (Manage Trustees privilege bypasses this setting) checkbox is not

checked in the General tab.

6. Next, open the Laserfiche client and log in to the repository using an administrator account.
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7. Select Access Rights... from the repository context menu.

8. In the dialog box that has opened, select the appropriate user in the Access Rights tab. If the user

is missing from the list, click Add… and select the user in the Create Access Control Entry

dialog box. Select This folder, subfolder and documents from the drop-down list, then click OK.
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9. In the Entry Access window, select the added user and enable the following options:
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10.Click OK.

Specifying output image options

The options available for output images (e.g. image format options or ability to redact fields containing

confidential information) are described in ABBYY FlexiCapture Help (look for the description of the

IExportImageSavingOptions interface).

In the Image Export Settings section of the export script or XML file, you can specify values for any of

the fields of the IExportImageSavingOptions interface in order to customize the output.

http://help.abbyy.com/en-us/flexicapture/12/distributed_administrator/iexportimagesavingoptions
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Specifying paths for document files within a Laserfiche repository

ABBYY FlexiCapture Connector for Laserfiche allows you to specify the path to a file and its name in

Laserfiche. When specifying a path and name, you can use predefined tags which will then be replaced

with data from an exported document. All the tags are supported that are available in the Destination

and File Naming Template dialog box where you can set up standard export procedures.

For instance, you can use the <Batch> tag to use the name of the batch as the name of the folder, or

use the <IndexField:FullPath> tag to access the value of any index field in a document. You can use the

<FolderPath> tag to set the export path and <FileName> tag to set the name of the file.

You can also specify conflict resolution rules for documents with identical file names:

NewVersion — check in a new version or, if there is no versioning control, overwrite the existing file;

NewName — add a unique suffix to the name of a new file if a file with this name already exists.

See Using a script to specify export settings, Using an XML file to specify export settings.

Field mapping

ABBYY FlexiCapture determines the type of each document that is being processed. Typically, for

documents of each type a separate Document Definition is created, which tells the program which fields

to capture. In a similar fashion, each document in Laserfiche corresponds to a certain template (the

default template is named General). A template may contain text fields, including typified fields.

If necessary, you can set up export of documents and fields from ABBYY FlexiCapture to specific

templates and fields in Laserfiche.

In ABBYY FlexiCapture, an export profile is created for each Document Definition separately. All you

need to do is specify the Laserfiche template to which to export documents of this type and map the

fields in the Document Definition to the fields in the Laserfiche template.

See Using a script to specify export settings, Using an XML file to specify export settings.

Testing the export settings

Once you have set up export of documents to Laserfiche, make sure  that you have saved and

published the modified Document Definition.

Upload a document satisfying this Document Definition, say, onto the Project Setup Station, recognize

the document, and export it. If everything works correctly, a new file should appear in the Laserfiche

repository.

Installing, configuring, and using the ABBYY

FlexiCapture component for Laserfiche Wokflow

Designer
The ABBYY FlexiCapture component for Laserfiche Workflow Designer is a dynamic-link library named

ABBYYFlexiCapture12.dll (the default path to the library is C:\Program Files (x86)\ABBYY

FlexiCapture Connector for Laserfiche\LaserficheWorkflowActivity).
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For detailed instructions on installing Workflow components, please refer to the Installing the Workflow

Components page in the Laserfiche documentation.

Adding the assembly

Adding the assembly to Workflow Administration Console

To add the assembly to Workflow Administration Console:

1. Open the Workflow Administration Console.

2. Expand the Server Configuration node of the Workflow server where you want to add the

activity.

3. Select Custom Activities.

4. Click Add Custom Activity Reference and add the ABBYYFlexiCapture12.dll assembly.

Note: When you click the Add Custom Activity Reference item, the following error may occur: "The
Workflow Server does not have file browsing enabled. [0620-WF1]".

To resolve the problem, complete the following steps:

1. In the Workflow Administration Console, expand the Security node.

2. Select File Browser Options and click Edit Options.

3. In the dialog box that opens, open the General tab and select Enable file browsing.

https://www.laserfiche.com/support/webhelp/Laserfiche/10/en-us/administration/#../Subsystems/LFWorkflow/Content/Resources/Configuration/Installation%20and%20Migration/Installing%20the%20Workflow%20Components.htm
https://www.laserfiche.com/support/webhelp/Laserfiche/10/en-us/administration/#../Subsystems/LFWorkflow/Content/Resources/Configuration/Installation%20and%20Migration/Installing%20the%20Workflow%20Components.htm
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Adding the assembly to Workflow Designer

To add the assembly to Workflow Designer:

1. Open Workflow Designer.

2. Right-click the Toolbox pane.

3. On the menu that opens, select Add/Remove Activities.

4. In the Add/Remove Toolbox Activities dialog box, click Add… 

5. The Add/Remove Toolbox Activities dialog box will open. In this dialog box, click Add… and

add the ABBYYFlexiCapture12.dll assembly. Once added, the assembly will become available

in the Toolbox pane in Custom Activities.
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ABBYY FlexiCapture activity

Activity Name – the name of the activity (default

property).

Activity Description – the description of the activity

(default property).

Connection Options – the connection options for

connecting to the FlexiCapture 12 server (custom

property). To connect to FlexiCapture 12, you must

complete all of the fields of this property:

· Server URL – the address of the FlexiCapture 12

server.

Note: If you work with a tenant, specify Server URL as
follows: http://<ApplicationServer>#<TenantName>,
where <ApplicationServer> is the name of the
computer on which the Application Server is installed and
<TenantName> is the name of your tenant.

· User name – the user name for the FlexiCapture 12

server.

· Password – the password for the FlexiCapture 12

server.

Note: The user must have an Administrator or
Scanning Operator rights in the project and batch type.
Access rights must be set up by a ABBYY FlexiCapture
administrator using the Administration and Monitoring
Console. For more information about setting up access
rights, see the Administration and Monitoring Console
help guide.

· Project – the name of the FlexiCapture project on the

server.

· Batch Type – the name of the batch type.

Entry – the data source (default property). There are two types of data sources:

· Starting Entry – the activity will act on the same Entries (i.e. documents/folders/shortcuts) as

received by the workflow. For example, if a business process is being performed, the Entry for the

activity will be the same folder received by the workflow.

· Other Entry – the activity will act on Entries resulting from other activities. Suppose your workflow

is as follows: Find Entries → For Each Entry → ABBYY FlexiCapture. When a business process is

started for a folder, the first activity (Find Entries) will receive the folder from which all the

documents are taken. Next, these documents are passed on to the next activity (For Each Entry).

The For Each Entry activity iterates through the documents and sends them to ABBYY

FlexiCapture one by one. Finally, the ABBYY FlexiCapture activity will send each document it

receives from For Each Entry to ABBYY FlexiCapture 12.

http://help.abbyy.com/en-us/flexicapture/12/monitoring_console/users
http://help.abbyy.com/en-us/flexicapture/12/monitoring_console/users
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Creating a workflow in Laserfiche

A workflow can be created either for all of the items stored in a folder/repository or for each individual

document.

Creating a workflow for a folder

To add a workflow to a repository as a business process, select the following options in the Business

Process Options property:

· Make this workflow a business process.

· Start this business process.

· Display this business process’s information.

Next, select the repository where you want to add the workflow.

To add an activity to the business process, simply select it in the Toolbox pane and drag it onto the

Workflow tab. In the Workflow properties on the right, you can change its Name and Description. In

the Connection Profiles property, you can add connections to repositories.
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Find Entries

This activity finds Entries based on user-defined parameters and passes them to the next activity in the

workflow.

Entries to Find – Defines how Entries should be found. In this particular case, documents will be taken

from the folders with the Entry ID token. The token will be replaced with ID of the input folder.

Filter Entries – This filter selects what types of Entries to pass to the next activity (documents, folders

or both).

For more detailed information, please refer to Online Help.

For Each Entry

This activity starts iterating through the Entries received. Each Entry will go through the activities

contained in the body of the iteration cycle.

Entries – the data source. In this particular case, Entries are received from the Find Entries activity. 

https://www.laserfiche.com/support/webhelp/Laserfiche/10/en-us/administration/#../Subsystems/LFWorkflow/Content/Resources/Activities/Find%20Entries.htm
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For more detailed information, please refer to Online Help.

https://www.laserfiche.com/support/webhelp/Laserfiche/10/en-us/administration/#../Subsystems/LFWorkflow/Content/Resources/Activities/For%20Each%20Entry.htm
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Creating a workflow for a file

Replace Find Entries with Find Entry and remove For Each Entry:

Once the workflow is assembled, you must publish it:

Note:  To prevent a user from starting business processes from Laserfiche Client, you should give the
user read-only access rights when adding the user to the list of repository users on the Laserfiche
Web Client Management page. Users with read-write access rights will be able to start business
processes.

Once the workflow is assembled and published as a business process, it can be started in Laserfiche

Client.
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Configuring the project in ABBYY FlexiCapture

The FlexiCapture project must be uploaded to the FlexiCapture server and the server must be running.

Make sure that the For each image file option is selected under Document separation on the Image

Preprocessing tab of the FlexiCapture project or batch type properties dialog box (any of the

parameters available for this option can be chosen).

In the Document Definition, configure data export to Laserfiche (see Configuring the export of data from

ABBYY FlexiCapture to Laserfiche), To do this, in the XML configuration file, set FolderPath to

"<FolderPath>" and set FileName to "<FileName>". Now the processing result (i.e. the template and

data) will be associated with the Laserfiche file that was originally sent to FlexiCapture.

Logging Laserfiche activity

All major export stages are logged. 

· Workflow Designer. When debugging a workflow, all activity logs will be displayed in design

mode. To view the logs, click the Messages tab after starting the activity.

· Business Process in Laserfiche Client. No logs are displayed in business process mode (i.e.

when starting the activity from Laserfiche Client). In this mode, you can only get information about

errors that occurred when executing the process. You can find the activity errors.log file in the

following folder on the computer hosting Laserfiche: C:\Program Files\Laserfiche\Laserfiche

Workflow 10.2\Logs\Errors.

Updating Laserfiche workflow activity
First, update the activity in the Workflow Administration Console:

1. Open the Workflow Administration Console.

2. In the navigation pane on the left, select Server Configuration → Custom Activities.



Connector for Laserfiche Administrator's Guide

3. In the Actions list on the right, select and delete the outdated version of the ABBYY FlexiCapture

activity.

4. Open Windows Services by pressing WIN+R and then entering the “services.msc” command.

Next, restart the Laserfiche Workflow 10.2 service.

5. Select Add Custom Activity Reference… and specify a path to an activity file for the new

version.
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6. The new activity version should now be displayed in the Assembly Name column.

7. Close the Workflow Administration Console.

Next, you must update the activity in Workflow Designer. Do the following:

1. Open Workflow Designer.

2. Click any of the activity groups in the left pane to open the context menu, then select Toolbox →

Add/Remove Activities….

3. In the Add/Remove Toolbox Activities dialog box, choose the outdated ABBYYFlexiCapture12

assembly and click Remove.
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4. Click Yes in the Remove Assembly dialog box. Then click OK in the Confirm Changes dialog

box to confirm the changes you have made.

5. Close and then open the Workflow Designer again and select Toolbox → Add/Remove

Activities… from the context menu for any activity group.

6. Click Add… and specify a path to an activity file for a new version.

7. Make sure that the new assembly version is specified for ABBYYFlexiCapture12 activity in the

Version column.
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8. Click OK to confirm the changes you have made.

9. Next, click File → Open Published Workflows… and select a workflow that uses an

ABBYYFlexiCapture12 activity, then click View.

10. In the workflow pane, select an ABBYYFlexiCapture12 activity and specify the  ABBYY

FlexiCapture project name and Batch Type in the Properties panel.
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11. Save and publish the workflow.

Additional Options: getting information about

Laserfiche repositories
The ABBYY FlexiCapture Connector for Laserfiche supports the following methods for getting

information about Laserfiche repositories:

· getting a list of repositories on the Laserfiche server

IRepositories[] IAfcDmsConnector.GetRepositories();

· getting a list of templates in the current repository, which is specified in an export script or an XML

file

IMetadataTemplate[] IAfcDmsConnector.GetMetadataTemplates();

· getting a list of fields in a template

IField[] IAfcDmsConnector.GetFields(IMetadataTemplate template);
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· getting the root folder of a repository and a list of subfolders

IFolder exportConnector.GetRootFolder();

IFolder[] exportConnector.GetChildFolders().

Troubleshooting
This section documents export connector errors and Laserfiche activity errors that can be encountered

during connector operation. This section also documents the possible causes of these errors, as well

as ways to resolve them.

Export connector errors

The list below contains a description of the errors that may occur when exporting documents from

ABBYY FlexiCapture to Laserfiche. These errors are recorded in the ABBYY FlexiCapture Processing

Server Monitor log, as well as in the ABBYY FlexiCapture Administration and Monitoring Console (Event

Log in the Processing Monitor tab).

· System.Exception: System.IO.FileNotFoundException: Could not load file or assembly

'Laserfiche.RepositoryAccess, Version=10.2.0.0, Culture=neutral,

PublicKeyToken=3f98b3eaee6c16a6' or one of its dependencies. The system cannot find the file

specified.  File name: 'Laserfiche.RepositoryAccess, Version=10.2.0.0, Culture=neutral,

PublicKeyToken=3f98b3eaee6c16a6'

o Laserfiche SDK Runtime is not installed on the ABBYY FlexiCapture Processing station.

Laserfiche SDK Runtime can be downloaded here: https://support.laserfiche.com.

· System.Exception: Abbyy.Connectors.Dms.Infrastructure.DmsConnectorException: An error

occurred while creating. Laserfiche.RepositoryAccess.LaserficheRepositoryException: A read-

only session is not permitted to perform this operation. [9105]

o Documents are being exported by a Laserfiche user that has the Only allow read-only access

property enabled. To get rid of the restriction, follow the steps outlined in Parameters for

connecting to the Laserfiche server.

o The server-side Laserfiche license does not allow non-readonly actions (for example, a Retrieval

license). Make sure that your license type allows you to perform the specified action. Information

about your license can be found in the Laserfiche Administration Console when choosing a

Laserfiche server.

· System.Exception: Abbyy.Connectors.Dms.Infrastructure.DmsConnectorException: An error

occurred while creating. Laserfiche.RepositoryAccess.AccessDeniedException: Access denied.

[9013]

o The Laserfiche user does not have the sufficient privileges to carry out the specified actions in

the repository. Make sure that the user has sufficient privileges assigned.

· System.Exception: Abbyy.Connectors.Dms.Infrastructure.DmsConnectorException: An error

occurred while creating. Laserfiche.RepositoryAccess.ObjectNotFoundException: Volume not

found. [9006]

o A Default volume has not been assigned to the export folder in the Laserfiche repository. Open

the repository using the Laserfiche client and check that the export destination folder, as well as

https://support.laserfiche.com/
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all folders above it, have a Default volume specified. To do this, go to the Folder tab in the folder

properties.

Laserfiche activity errors

The list below contains a description of errors that may occur when exporting documents from

Laserfiche to ABBYY FlexiCapture for processing. These errors are recorded in the Laserfiche Workflow

Designer log when launching a workflow (Messages tab).

· Cannot export the document to FlexiCapture.

Abbyy.Connectors.FlexiCaptureExport.FlexiCaptureExportException: Cannot open the session.

System.Net.WebException: Unable to connect to the remote server

---> System.Net.Sockets.SocketException: A connection attempt failed because the connected

party did not properly respond after a period of time, or established connection failed because

connected host has failed to respond

o This error may be caused by issues with the firewall. Check that the machines running the

Laserfiche have permission to send requests to the machine running the ABBYY FlexiCapture

Application Server (this includes its ports). By default, the ABBYY FlexiCapture Application Server

uses port 80 (for HTTP) and port 443 (for HTTPS).

o Make sure that access to the ABBYY FlexiCapture Application Server is set up for the protocol

specified in the Server URL field, and that it is specified correctly.

· Cannot export the document to FlexiCapture.

Abbyy.Connectors.FlexiCaptureExport.FlexiCaptureExportException: Cannot open the session.

System.Net.WebException: Unable to connect to the remote server

---> System.Net.Sockets.SocketException: No connection could be made because the target machine

actively refused it

o The ABBYY FlexiCapture Application Server cannot be found using the specified Server URL.

Make sure that the address of the machine running the ABBYY FlexiCapture Application Server is

specified correctly in the Server URL field.
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