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About the ABBYY FlexiCapture Connector for M-Files
ABBYY FlexiCapture enables users to perform high-quality full-text recognition, classify documents,

detect fields and capture their data, and convert files into various formats (e.g. searchable PDF).

ABBYY FlexiCapture Connector for M-Files is intended for sending document files from M-Files to

ABBYY FlexiCapture and loading document files and captured data into the M-Files document

management system.

Architecture
The ABBYY FlexiCapture Connector for M-Files includes the following components intended for loading

files and metadata into M-Files:

· DmsConnector.dll, a library of classes used to convert data from an abstract DMS into ABBYY

FlexiCapture data.

· AfcDmsConnector.dll, a library accessed by the ABBYY FlexiCapture export script. This library

accepts ABBYY FlexiCapture objects as input, converts them, and passes them on to the ABBYY

FlexiCapture Connector for M-Files

· Abbyy.FlexiCapture.MFiles.Connector.dll, a connector for M-Files. This library provides a simplified

programming interface to interact with the M-Files server via the M-Files Web Service.

The following libraries are used to send document files from M-Files to ABBYY FlexiCapture:

· Abbyy.MFiles.FlexiCapture.Activity.dll;

· Abbyy.Connectors.FlexiCaptureConnector.dll.

System requirements
The ABBYY FlexiCapture Connector for M-Files supports:

· ABBYY FlexiCapture 12 Distributed (12.0.2.3042) and ABBYY FlexiCapture Cloud;

· M-Files 2018 (19.2.7378.4 or higher).

Export will be performed on the ABBYY FlexiCapture Processing Stations.

The ABBYY FlexiCapture Connector for M-Files requires Microsoft .NET Framework 4.5 to be installed

on all of the computers where export will be performed and on the M-Files server.

Important! To be able to send documents from M-Files to ABBYY FlexiCapture, you need to open the
following port in the firewall to the Application Server: port 80 (if HTTP is used) or port 443 (if HTTPS is
used). To be able to export documents from ABBYY FlexiCapture to the M-Files server, you need to open
the port on the M-Files server via which the web server can be accessed. By default, this is port 80 (if
HTTP is used) or port 443 (if HTTPS is used).

Installation
The ABBYY FlexiCapture Connector for M-Files is distributed as a self-extracting archive that includes

all the required libraries and samples.
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Configuring export of data from ABBYY FlexiCapture

to M-Files
In ABBYY FlexiCapture, documents are processed within projects. ABBYY FlexiCapture will identify the

type of each document and apply the appropriate Document Definition that has been prepared

specifically for that type. Each Document Definition includes one or more export profiles to be used for

exporting document images and data. If you are not familiar with the aforementioned concepts, please

refer to the ABBYY FlexiCapture documentation, where you will find a detailed description of the capture

process. To set up the export of data from ABBYY FlexiCapture, you will need to create a new script

export profile in your ABBYY FlexiCapture project.

Before setting up the connector, please make sure that you have the following software installed:

· ABBYY FlexiCapture 12 Project Setup Station (required if you are using ABBYY FlexiCapture

Distributed Edition or ABBYY FlexiCapture Cloud).

You will also need access rights to M-Files.

If you already have an ABBYY FlexiCapture project for which you need to set up data export to M-Files,

open that project. Otherwise, you will need to create a project. Launch the Project Setup Station and in

the Open Project dialog box click:

· Create New... to create a new project.

· Browse... to open an existing project stored on your local drive.

· Browse from Server...  to a open a project that you earlier uploaded to the ABBYY FlexiCapture

Application Server.

Note: The distribution package includes a sample ABBYY FlexiCapture project named
"InvoiceDemoProject" with a preconfigured profile for exporting data to M-Files. To open this project for
editing, unzip the InvoiceDemoProject.zip archive located in Samples\FlexiCapture Project and open
the InvoiceDemoProject.fcproj file on the Project Setup Station.

http://help.abbyy.com/
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Next, you need to upload the project on to the ABBYY FlexiCapture Application Server. To do this, click

File → Upload Project to Server... and in the Upload Project to Application Server dialog box

specify the address of the server, the protocol to be used, and your credentials.

If you are using ABBYY FlexiCapture Cloud, complete the URL field, specifying one of the following three

FlexiCapture Cloud instances (you should specify the instance that your company is registered in):

· https://europe.flexicapture.com

· https://australia.flexicapture.com

· https://usa.flexicapture.com

In the Tenant name field, specify the name of your company, select the Use server authentication

option, and enter your credentials. Next, click Test Connection to check that you have entered the

correct data. Finally, click OK to upload the project to the Application Server.

Note: When uploading a project to the cloud or when opening a project from the cloud, the following
error may occur: "Application server version is not compatible." If you see this error, the version of your
Project Setup Station does not match the version of the cloud-based Application Server. To obtain a
compatible version of ABBYY FlexiCapture, please contact the ABBYY sales office servicing your region
(see https://www.abbyy.com/contacts).

When you see the "Operation completed" message, click Close. In the next dialog box, click Yes to

open the uploaded project from the server.

https://www.abbyy.com/contacts
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To set up export of data from ABBYY FlexiCapture to M-Files, complete the following steps:

· Add the assemblies of the ABBYY FlexiCapture Connector for M-Files to your ABBYY FlexiCapture

Document Definition.

· Create an export profile in your Document Definition.

· Specify export settings and map fields.

Adding the assemblies to a Document Definition

Before you can configure document export, you must add the assemblies to your ABBYY FlexiCapture

project. To add the assemblies, complete the following steps:

1. Open the project in the ABBYY FlexiCapture Project Setup Station.

2. Click Project → Document Definitions... to open the list of Document Definitions available for

the project, select the Document Definition for which you want to specify new export settings, and

click Edit....

3. Click Document Definition → Document Definition Properties... to open the properties of the

Document Definition and then click the .Net References tab.

4. Click the Add... button on the .Net References tab. In the Add Assembly dialog box, select

Attached file from the Type drop-down list, and in the Reference field, specify the path to the

DLL file that you wish to add. Repeat this step for the AfcDmsConnector.dll,

DmsConnector.dll, and Abbyy.FlexiCapture.MFiles.Connector.dll files from the Bin folder in

the connector distrbution package.

Creating an export profile

ABBYY FlexiCapture exports data based on the export profiles in the Document Definitions.

To create an export profile for M-Files:

1. On the Project Setup Station open your ABBYY FlexiCapture project.

Note: Make sure that all the necessary assemblies are added to the Document Definition.

2. Click Project → Document Definitions... to open the list of Document Definitions available for

the project, select the Document Definition for which you want to specify new export settings, and

click Edit....

3. Click Document Definition → Export Settings....

4. Click the Add... button to start the export profile creation wizard.

5. In the Select the Type of Destination step, select Custom export (script) from the Type drop-

down list and then select Errors are irrelevant in the Document condition field. Leave the other

settings unchanged or modify them as described in ABBYY FlexiCapture Help.

6. In the Script Export step, click the Edit Script... button, select C# .Net script language, and

paste into the script editor one of the two sample scripts provided in the Samples folder in the

connector distribution package: M-Files - ExportScript - Configure by script.cs or M-Files -

http://help.abbyy.com/en-us/flexicapture/12/standalone_administrator/export_main
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ExportScript - Configure by XML.cs. For detailed instructions on using each of these scripts,

see Using a script to specify export settings and Using an XML file to specify export settings

below. You can always edit this script later, but for the moment, save the changes and close the

script editor. Detailed instructions for setting up your export script will be provided below.

7. In the Select the Destination Name step, specify a name for your export profile and click Finish.

8. The newly created export profile will appear in the list of available export profiles in the export

settings dialog box. To make ABBYY FlexiCapture use this profile on Export stage, select the box

next to the profile in the Enabled column.

9. Click OK, then save and close the Document Definition editor. Next, click the Publish button to

publish your Document Definition.

Note: If documents are being processed within the project at the time when you add your new export
profile, update them to the latest version by pressing Alt+Shift+U or by selecting Update to Latest
Version from their shortcut menu.

Using a script to specify export settings

One advantage of using a script is that all the export settings will be automatically used by all the ABBYY

FlexiCapture stations from which data are exported to M-Files. When using an XML file, you can only

specify static settings, whereas scripts allow you to specify different file naming rules, file locations, and

field mappings depending on the data contained in the exported document.

When working with ABBYY FlexiCapture Cloud, you also need to use a script to specify export settings,

since ABBYY FlexiCapture Cloud does not provide the ability to store an XML file with configuration on

processing stations.

However, to modify the export settings, you will have to make changes to the script and, consequently,

publish a new version of the Document Definition.

Please use the script named M-Files - ExportScript - Configure by script.cs from the Samples

folder in the connector distribution package.

Using an XML file to specify export settings

One advantage of using an XML file is that you don’t have to edit the script code or the Document

Definition. All modifications can be made by editing the XML file, which is much simpler than editing the

script code. However, the XML file should be located on every ABBYY FlexiCapture processing station.

And you will also have to synchronize it manually on all of the ABBYY FlexiCapture stations from which

data is to be exported to M-Files.

To specify export settings in an XML file:

1. As your export script, use the M-Files - ExportScript - Configure by XML.cs from the Samples

folder of the connector distribution package.

2. Create an XML file named <Project name>_<Document Definition name>.xml. This naming

scheme will allow you to have multiple XML files for different Document Definitions.

3. In the registry of the computer with a processing station, locate

HKEY_LOCAL_MACHINE\SOFTWARE\ABBYY\FlexiCapture\12.0\Connectors\MFiles and in its

"XmlFolder" string value field, specify the path to the folder where the settings file is to be stored.
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4. In the registry of the computer with a processing station, locate the

HKEY_LOCAL_MACHINE\SOFTWARE\ABBYY\FlexiCapture\12.0\Connectors\ and set its

"MFiles" string value field to true.

Note: For an example of an XML configuration file with detailed comments, please see the
default.config.xml file that is located in the Samples folder of the connector distribution package. In the
code of M-Files - ExportScript - Configure by XML.cs, you can also find some other possible naming
schemes for your XML files.

Specifying export settings and mapping fields

This section describes the fields of the M-Files - ExportScript - Configure by script.cs and

default.config.xml configuration file.

Server  contains the URL to be used for accessing to M-Files over the Internet. For example,

<Server>http://m-files-server</Server>.

Note: For detailed instructions on configuring web access, please refer to the M-Files User Guide.

Username contains the name of the user in M-Files. This may be either a domain name, or a local

name on M-Files Server. For example, <Username>username</Username>.

Password contains the user's password. For example, <Password>password</Password>.

Repository contains the name of the document vault in M-Files. For example,

<Repository>DocumentVault</Repository>.

FolderPath contains the object type name. For example, <FolderPath>Document</FolderPath>.

FileName contains the name of the document that will be created at the time of export. For example,

<FileName>&lt;Batch&gt;_&lt;Identifier&gt;</FileName>.

Note: The name of the document may have an unchanging static part and a changing dynamic part.
The dynamic part is defined by tags, which are replaced by the ABBYY FlexiCapture document property
values at the time of export. Each tag must be enclosed in angle brackets. In the XML file:

· ‘&lt;’ stands for ‘<’;

· ‘&gt;’ stands for ‘>’.

Possible tags for the dynamic part of the name:

· Project for the name of the project in ABBYY FlexiCapture;

· Batch for the name of the batch;

· DocumentDefinition for the name of the Document Definition in ABBYY FlexiCapture;

· SourceFile for the name of the source file;

· Identifier for the document identifier in the batch;

· BatchType for the name of the batch type;

· Time for the current time in yyyy-MM-dd_HH-mm-ss format.

https://www.m-files.com/user-guide/latest/eng/enabling_web_and_mobile_access.html
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Note: You can use dynamic replacement tags '<FolderPath>', '<Template>,' and '<FileName>' to
update documents sent from M-Files to FlexiCapture for processing. If the FlexiCapture batch was
created by the M-Files workflow activity "Abbyy.MFiles.FlexiCapture.Activity.dll":

· A runtime replacement tag '<FolderPath>' can be used in the FolderPath configuration field

instead of an explicit object type name.

· A '<Template>' tag can be used in the DmsMetadataTemplate configuration field instead of an

explicit class name.

· A '<FileName>' tag can be used in the FileName instead configuration field of an explicit document

name.

These tags are replaced with the value of the batch registration parameters. The batch registration

parameters are created by the M-Files workflow activity. The original document in M-Files will be

updated based on these registration parameters. These dynamically replaceable tags are case-

sensitive and the register of the characters used in the tags above should be preserved.

The following is an example of a document name with a static part:

<FileName>My_static_prefix_&lt;DocumentDefinition&gt;_&lt;Identifier&gt;and_postfix</FileName>

The following is an example of a document name without a static part:

<FileName>&lt;Project&gt;_&lt;Identifier&gt;</FileName>

NameConflictResolution is used to resolve name conflicts. Possible values: 

· NewVersion – A new version of the document will be created. 

· NewName – A new document with a new name will be created. 

 For example,

<CreationPolicy> 

  <NameConflictResolution>NewVersion</NameConflictResolution> 

</CreationPolicy>

Note: The NewVersion option allows updating the document in M-Files if the name and format
specified in the script match the name and format of the document in M-Files. If the names and formats
of the two documents do not match, a new document will be created in M-Files.

DmsMetadataTemplate contains the name of the document class in M-Files. For example,

<DmsMetadataTemplate>

  <Name>Invoice</Name>

</DmsMetadataTemplate>

FieldPairs contains a collection of field pairs. This collection is used for mapping ABBYY FlexiCapture

document definition fields to M-Files property definitions.

If your export settings are stored in an XML file, map the fields as follows:
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<FieldPairs>

 <FieldPair>

   <AfcField>Invoice\InvoiceNumber</AfcField>

   <DmsField>InvoiceNumber</DmsField>

 </FieldPair>

</FieldPairs>

where:

· AfcField is the full path to the FlexiCapture Document Definition field from which data are to be

read at the time of export.

· DmsField is the name of the M-Files property definition where data will be written at the time of

export.

If your export settings are specified in the script, map the fields in a dictionary as follows:

Dictionary<string, string> pairs = new Dictionary<string, string>()

{

    { @"Invoice Layout\InvoiceNumber", "Invoice number" },

    { @"Invoice Layout\InvoiceDate", "Invoice date" },

};

In the pairs above, the value before the comma is the full name of a field in the ABBYY FlexiCapture

Document Definition and the value after the field is the name of the respective property definition in M-

Files.

SaveDocumentImages – Specifies whether or not to export the image. When set to true, the connector

will send both the document image and the extracted fields to M-Files; otherwise, only the extracted

fields will be sent to M-Files.

ExportImageSavingOptions contains the image saving options to be used at the time of export, such

as the format of the exported image, its quality, and redacted areas. For a detailed description of the

image saving options, please refer to ABBYY FlexiCapture Developer's Help.

DmsSpecificOptions – These are settings specific to M-Files:

· Workflow – The name or alias of the workflow that will be assigned to the document once export

from ABBYY FlexiCapture to M-Files is complete (optional). For example,

<DmsSpecificOptions>

    <Option>

      <Name>Workflow</Name>

      <Value xsi:type="xsd:string">Invoice.Workflow</Value>

    </Option>

  </DmsSpecificOptions>

http://help.abbyy.com/en-us/flexicapture/12/developer/iexportimagesavingoptions
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Configuring M-Files metadata structure

To map ABBYY FlexiCapture document definition fields to M-Files property definitions, you must first

configure metadata structure in M-Files Admin on your M-Files server.

To configure metadata structure for the main document, please do the following:

1. In built-in Document object type (or your custom object type) create a class for the main

document (i.e. Invoice). It will represent the type of documents you will work with.

2. In the class properties create and add property definitions that will represent metadata fields. One

of these fields should be a Set as name field that will be used for setting the document's name.

3. If you are not using the built-in Set as name property "Name or title", you should select the Allow

searching for objects by this property option in the General tab.

To configure metadata structure for LineItems, please do the following:

1. Create an object type that will represent one line in LineItems. When you create this object type, a

property definition with the same name will be created automatically, allowing you to link objects of

this type to the main document object.

Important! The object type you create for LineItems must have only one class. This class will be
used to represent LineItems data. You must add property definitions into this class, each corresponding
to a table column in the ABBYY FlexiCapture Document Definition.
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To name objects in this class, select a property definition on the template that must always be filled in.

Alternatively, you can create a property definition with an automatic value and define it as the name of

the objects (on the Automatic Values tab of the Property Definition dialog box, select Set As Name).

For a more clear representation of the data, you can use the Simple concatenating of properties

option for the Automatic value by adding the required properties of the class, created for LineItems, to

the placeholders.

2. In the class created for the main document, create a property definition of the Choose from list

(multi-select) data type, which will link one Invoice object to multiple Line Item objects (this

property definition must show values from the list of LineItem object types).

Note: You can use the property definition that was created automatically when you added the
LineItem object type.
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When mapping Line Items in script or in the XML file, please specify the property definition for LineItems

name in the main document and property definition in the class for Line Items in the following format:

Important! When mapping the ABBYY FlexiCapture document definition fileds to the M-Files property
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definitions, make sure that data type of each ABBYY FlexiCapture document definition field is identical in
nature to its chosen M-Files counterpart. Recommended correspondences are listed in the table below:

Field data types in ABBYY FlexiCapture Property definition data types in M-Files

Address Text

Amount of  Money Number (real) or Text

Checkmark Boolean (y es/no)

Code Text

Date Date

Name Text

Number Number (real), Number (integer), or Text

Text Text or Text (multi-line)

Time Time

M-Files workflow activity: installation and use
In order to send files from M-Files to FlexiCapture, an M-Files workflow should be created. In this

workflow, you need to create a state where a file sending script will be executed. This script will call

methods from the connector libraries, which should be installed on the M-Files server. To install the

libraries, complete the following steps:

1. Copy the following files from the M-Files Workflow Activity folder in the distribution package into

any folder on the M-Files server:

· Abbyy.MFiles.FlexiCapture.Activity.dll;

· Abbyy.Connectors.FlexiCaptureConnector.dll.

2. Run the Command Prompt as administrator, go to the folder where the libraries were placed in

step 1, and execute one of the following commands (to register the library in the registry):

· If you are using a 64-bit M-Files server version:

%SystemRoot%\Microsoft.NET\Framework64\v4.0.30319\RegAsm.exe Abbyy.MFiles.FlexiCapture.Activity.dll /codebase

· If you are using a 32-bit M-Files server version:

%SystemRoot%\Microsoft.NET\Framework\v4.0.30319\RegAsm.exe Abbyy.MFiles.FlexiCapture.Activity.dll /codebase

Then restart the M-Files Server 2018 service.

Important!  To remove the Abbyy.MFiles.FlexiCapture.Activity.dll library from the registry, run the
Command Prompt as administrator, go to the folder where the libraries were placed in step 1, and
execute one of the following commands:

· If you are using a 64-bit M-Files server version:

%SystemRoot%\Microsoft.NET\Framework64\v4.0.30319\RegAsm.exe Abbyy.MFiles.FlexiCapture.Activity.dll /u

· If you are using a 32-bit M-Files server version:

%SystemRoot%\Microsoft.NET\Framework\v4.0.30319\RegAsm.exe Abbyy.MFiles.FlexiCapture.Activity.dll /u
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Note:  To update Abbyy.MFiles.FlexiCapture.Activity.dll, you need to unregister the previously
registered version of the library and register the new version of the library. For the changes to take
effect, restart the M-Files Server service.

If the library is registered successfully, the following keys will be added to the registry:

· HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Abby y .MFiles.FlexiCapture.Activ ity .ConnectionSettings

· HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Abby y .MFiles.FlexiCapture.Activ ity .FlexiCaptureWebClient

· HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Abby y .MFiles.FlexiCapture.Activ ity .MFilesTargetContext

· HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Abby y .MFiles.FlexiCapture.Activ ity .RegistrationParameter

The connector distribution package contains a sample vault named "FlexiCapture Demo Vault." This

sample vault already includes a metadata structure for invoices and two preconfigured workflows, one

for unattended processing and one for processing with verification. Unzip the FlexiCapture Demo

Vault.zip archive. Import this vault to the M-Files server. In the Index file on the server field, provide

the path to the file: \FlexiCapture Demo Vault\Index.xml. Next, add to this vault M-Files users that will be

working with it. For the scripts in the workflow to work correctly, you must specify your connection

settings to be used to connect to the ABBYY FlexiCapture Application Server. These settings should be

specified in the head section of each script.

Modify the scripts as follows:

1. In M-Files Admin, open the FlexiCapture Demo Vault that you have imported and click Workflows.

2. Select one of the workflows and start editing the In Processing by FlexiCapture state. Then

click the Actions tab, select the Run Script option, and click Edit Code....

https://www.m-files.com/user-guide/latest/eng/Import_content.html
https://www.m-files.com/user-guide/latest/eng/How_can_I_add_a_new_user_to_the_document_vault.html
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3. In the Edit VBScript Code dialog box, specify the following variable values in the code of the

script:

· szFCServerUrl = "http://FlexiCapture"

· szFCUsername = "Username"

· szFCPassword = "Password"

If you are using ABBYY FlexiCapture Cloud, modify the script as follows:

1. In the szFCServerUrl variable, specify the URL of the FlexiCapture Cloud instance that your

company is registered in.

2. Uncomment line 3 of the script and specify the name of your company here:

szCompany = "Company" '(Optional) Set tenant name.

3. Specify the credentials to be used for your company's tenant in ABBYY FlexiCapture Cloud:

· szFCUsername = "Username"

· szFCPassword = "Password"

4. Uncomment line 22 of the script to use the name of your company when connecting to the ABBYY

FlexiCapture server:

oClient.ConnectionSettings.Company = szCompany = "Company" '(Optional) Set tenant name. 
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Make identical changes in the other sample workflow.

Note:  The connector distribution package also contains a sample FlexiCapture project named
"InvoiceDemoProject," which is configured to be used in conjunction with the sample vault. For the
scripts to run correctly in the FlexiCapture Demo Vault, be sure to complete the steps described in the
"Setting up an InvoiceDemoProject project in ABBYY FlexiCapture" section.

A workflow in M-Files can be configured for either

· unattended processing of documents in ABBYY FlexiCapture

 or

· processing of documents in ABBYY FlexiCapture with verification.

Each configuration requires its own script.

Note:  The sections that follow contain scripts used for configuring M-Files workflows. To set batch
registration parameters replace the code fragment iBatchId = oClient.SendTarget(szFCProject,
szFCBatchType) in this these scripts with the following code:
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' --------------- Send target with registration parameters --------------- '

' Set FlexiCapture batch registration parameters.

Set oRegParam0 = CreateObject("Abbyy.MFiles.FlexiCapture.Activity.RegistrationParameter")

oRegParam0.Name = "Name_0"

oRegParam0.Value = "Value_0"

' Set oRegParam1 = CreateObject("Abbyy.MFiles.FlexiCapture.Activity.RegistrationParameter")

oRegParam1.Name = "Name_1"

oRegParam1.Value = "Value_1"

arRegParams = Array(oRegParam0, oRegParam1)

' Sends the target document to FlexiCapture.

iBatchId = oClient.SendTarget_2(szFCProject, szFCBatchType, arRegParams)

' ------------------------------------------------------------------------ '

This code creates Abbyy.MFiles.FlexiCapture.Activity.RegistrationParameter objects for each

registration parameter. These objects are assigned the values Name and Value. Next, these objects are

sent to an array. To send a file to ABBYY FlexiCapture, the SendTarget_2 method is called, which

receives the name of the project, the name of the batch type, and the array containing the registration

parameters.

For detailed information about using registration parameters, see FlexiCapture 12 Standalone

Administrator's Help.

Setting up an InvoiceDemoProject project in ABBYY FlexiCapture

The connector distribution package contains a sample FlexiCapture project named

"InvoiceDemoProject," which is configured to be used in conjunction with the sample vault. To start

working with this project, open it on the ABBYY FlexiCapture Project Setup Station and upload it on to

the FlexiCapture Application Server.

Click Project → Batch Types... to open the list of batch types. The InvoiceDemoProject project

contains two batch types:

· Unattended service – This batch type is configured to be used in the scenario where documents

are sent from M-Files to ABBYY FlexiCapture for automatic processing.

· Attended service – This batch type is configured to be used in the scenario where documents

sent from M-Files may require verification.

A script is used to export processing results to M-Files. In the script, specify the connection settings to

be used to connect to the M-Files server: 

http://help.abbyy.com/en-us/flexicapture/12/standalone_administrator/reg_params
http://help.abbyy.com/en-us/flexicapture/12/standalone_administrator/reg_params
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1. Open the project on the Project Setup Station and press Ctrl+T to open the list of Document

Definitions.

2. Select the Document Definition named "European Invoice" and click Edit....

3. In the Document Definition Editor dialog box, click Document Definition → Document

Definition Properties....

4. On the Export Destinations tab, start editing the script for the Export to MFiles export profile.

5. Specify the connection settings to be used to connect to the M-Files server in the following lines:

· connectorSettings.DmsConnectionSettings.Server = "http://M-Files-server"

· connectorSettings.DmsConnectionSettings.Credentials.Username = @"username"

· connectorSettings.DmsConnectionSettings.Credentials.Password = "password"

6. Save the changes and publish the Document Definition.

Configuring an unattended document processing scenario

Configuring an M-Files workflow

To configure unattended processing of documents in ABBYY FlexiCapture, complete steps 1 and 2

described in the "M-Files workflow activity: installation and use" section and then: 

1. In the M-Files Admin application, navigate to Connections to M-Files Server → Local

Computer → Document Vaults → <Vault_Name> → Workflows and create a workflow by

clicking the New Workflow… button. Alternatively, you can modify your current workflow.

2. Select the workflow that you just set up and create a state by clicking the New State button.

3. In the Name field, type a name for the state (e.g. "In Processing by FlexiCapture").

4. On the Actions tab of the State Properties window, select the Run script option and click Edit

Code….

Note:  For further information regarding workflow state actions, please see the M-Files User Guide.

5. Paste the following script into the Edit VBScript Code window and provide your ABBYY

FlexiCapture connection settings, the project name, and the batch type that you are going to use.

When executed, this script will send a document from M-Files to ABBYY FlexiCapture for further

processing. The script will stop once the file has been sent.

https://www.m-files.com/user-guide/2018/eng/State_actions.html


20

ABBYY® FlexiCapture® 12 Connector for M-Files Administrator̀ s guide

' FlexiCapture connection settings.

szFCServerUrl = "http://FlexiCapture"

'szCompany = "Company" '(Optional) Tenant name.

szFCUsername = "Username"

szFCPassword = "Password"

szFCProject = "Project"

szFCBatchType = "BatchType"

' Creates FlexiCapture client. The assembly Abbyy.MFiles.FlexiCapture.Activity.dll must be

registered before.

Set oClient = CreateObject("Abbyy.MFiles.FlexiCapture.Activity.FlexiCaptureWebClient")

' Sets the target document context.

oClient.TargetContext.Vault = Vault

oClient.TargetContext.ObjVer = ObjVer

oClient.TargetContext.PropertyValues = PropertyValues

' Sets FlexiCapture connection settings.

oClient.ConnectionSettings.ServerUrl = szFCServerUrl

'oClient.ConnectionSettings.Company = szCompany '(Optional) Set tenant name.

oClient.ConnectionSettings.Username = szFCUsername

oClient.ConnectionSettings.Password = szFCPassword

' Sends the target document to FlexiCapture.

iBatchId = oClient.SendTarget(szFCProject, szFCBatchType)

Important!  The ABBYY FlexiCapture user whose credentials will be specified in the script must have
either the Scanning Operator role for the project and batch type specified in the script or the
Administrator role.

This script sends documents to ABBYY FlexiCapture using the M-Files Workflow Activity library. The

script code is provided in the M-Files Workflow Activity folder in the connector distribution package (M-

Files workflow – Send to FlexiCapture.vbs). Please be sure to specify the correct ABBYY

FlexiCapture connection settings, project name, and batch type. For further instructions on creating

VBScript code in M-Files, please see the "Available VBScript Variables" and "How do I write VBScript

code for M-Files purposes" sections from the M-Files User Guide.

6. Close the Edit VBScript Code window and click OK.

7. Create a new state and give it a name (e.g. "Waiting for approval") by repeating steps 1 through

3. This state will indicate that the document is ready for approval.

https://www.m-files.com/user-guide/2018/eng/Variables.html
https://www.m-files.com/user-guide/2018/eng/faq_how_do_i_write_a_visual_basic_script.html
https://www.m-files.com/user-guide/2018/eng/faq_how_do_i_write_a_visual_basic_script.html
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Below we provide a sample workflow for unattended processing of documents in ABBYY FlexiCapture.

Configuring an ABBYY FlexiCapture project

Important!  Make sure that Unattended is selected as the schema for the workflow in the
FlexiCapture project. This mode is used for processing documents without operator involvement. To
select this mode in ABBYY FlexiCapture, click Batch Type Properties → Workflow (or Project →
Project properties for the "Default" batch type) and select Schema: Unattended.

Important!  You must also configure an export profile in the ABBYY FlexiCapture project, which will
send processing results back to M-Files.

Configuring a document processing with verification scenario

Configuring an M-Files workflow

To configure the processing of documents in ABBYY FlexiCapture with verification, complete steps 1

and 2 described in the "M-Files workflow activity: installation and use" section and then:

1. In the M-Files Admin application navigate to Connections to M-Files Server → Local

Computer → Document Vaults → <Vault_Name> → Workflows and create a workflow by

clicking New Workflow… button. Or modify your current workflow.

2. Select the workflow that you just set up and create a state by clicking New State button.

3. In the Name field, type a name for the state (e.g. "In Processing by FlexiCapture").

4. On the Actions tab of the State Properties window select the Run script option and click Edit

Code….

5. Paste the following script to the Edit VBScript Code window and provide your FlexiCapture

connection settings, project name and batch type that you are going to use:
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' FlexiCapture connection settings.

szFCServerUrl = "http://FlexiCapture"

'szCompany = "Company" '(Optional) Set tenant name.

szFCUsername = "Username"

szFCPassword = "Password"

szFCProject = "InvoiceDemoProject"

szFCBatchType = "Default"

' M-Files settings.

iVerificationUrlPropDef = 1024 'ID of an M-Files property for verification URL.

' Creates FlexiCapture client. The assembly Abbyy.MFiles.FlexiCapture.Activity.dll must be
registered before.

Set oClient = CreateObject("Abbyy.MFiles.FlexiCapture.Activity.FlexiCaptureWebClient")

' Sets the target document context.

oClient.TargetContext.Vault = Vault

oClient.TargetContext.ObjVer = ObjVer

oClient.TargetContext.PropertyValues = PropertyValues

' Sets FlexiCapture connection settings.

oClient.ConnectionSettings.ServerUrl = szFCServerUrl

'oClient.ConnectionSettings.Company = szCompany '(Optional) Tenant name.

oClient.ConnectionSettings.Username = szFCUsername

oClient.ConnectionSettings.Password = szFCPassword

' Sends the target document to FlexiCapture.

iBatchId = oClient.SendTarget(szFCProject, szFCBatchType)

' Try to get verification URL.

szVerificationUrl = oClient.GetVerificationUrl(szFCProject, iBatchId)

' Update verification URL for the target document.

Set oVerificationUrlPropVal = CreateObject("MFilesAPI.PropertyValue")

oVerificationUrlPropVal.PropertyDef = iVerificationUrlPropDef

oVerificationUrlPropVal.Value.Value = szVerificationUrl

Vault.ObjectPropertyOperations.SetProperty ObjVer, oVerificationUrlPropVal

Important!  The ABBYY FlexiCapture user whose credentials will be specified in the script must have
the Scanning operator, Verification Operator and External User roles for the project and batch type
specified in the script, or the Administrator role.

Note:  The above script, running in "In processing by FlexiCapture" state, sends documents to ABBYY
FlexiCapture for further processing. The "In processing by FlexiCapture" state will cease, if the
document stops at the verification stage in ABBYY FlexiCapture, or if the document skips the verification
stage due to its high quality. If the document stops at the verification stage, a URL will be generated
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linking to the task created for this document on the Web Verification Station. This URL will be written to
the document properties in M-Files.

6. Close the Edit VBScript Code window and click OK button.

7. To enable the "In processing by FlexiCapture" state to use a script to generate URLs for

documents, you need to create a corresponding property. To do this, click Connections to M-

Files Server → Local Computer → Document Vaults → <Vault_Name> and add a new 

property definition to the document class:

8. In the Property Definition Properties - New Property Definition dialog box, type a name for

the property (e.g. "Verification URL") in the Name field and specify Data type: Text, Content:

Text. In the script code, assign the ID of the property to the iVerificationUrlPropDef variable.

Note:  To find out the ID of the newly created property, select the Admin vault in M-Files and expand
the Metadata Structure (Flat View) list. Next, select Property Definitions. The list of all property
definitions will be displayed in the ID column on the right:
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9. Create a new state and give it a name (e.g. "Waiting for verification") by repeating steps 1 through

3. 

10. The "Waiting for verification" state indicates that the document will stop at the verification stage in

ABBYY FlexiCapture. You can set up the document to go into this state if there is a link to the

verification stage in the Verification URL field in the document properties:

You can click this URL to verify the document URL. Once the document is verified, it will be sent to

the export stage in ABBYY FlexiCapture.

11. Create a new state and give it a name (e.g. "Waiting for approval") by repeating steps 1 through

3. You can set up the document to go into this state if certain required fields of the document are

filled in:
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This state indicates that the document is ready for approval.

Below we provide a sample workflow for processing of documents in ABBYY FlexiCapture with

verification:

Configuring your ABBYY FlexiCapture project

Important!  For the correct operation of the verification scenario, the workflow requires some
additional configuration in ABBYY FlexiCapture.

1. To configure the workflow in ABBYY FlexiCapture, click Project → Project properties, select

Schema: Advanced on the Workflow tab, then select the Verification and click Edit....
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2. On the General tab, select the Enable web stations option and click OK.

3. Create a new User type stage after the Verification stage by clicking Stage....

4. On the General tab, type Mark No Verification in the Name field (be sure not to use any other

name for this stage). Clear the linked to previous option.

5. On the Entry Conditions tab, select the Under these conditions option and add a new rule by

clicking Rule....

6. In the Rule Settings dialog box, select Condition type: Script, open the script editor, select

Script Language: C# .Net, and paste the following script code:

Result.CheckSucceeded = (Document.StageInfo.StageName != "Verification Postprocessing" &&

Document.StageInfo.StageName != "Verification");

7. Click OK.

Important!  You must also configure an export profile in the FlexiCapture project that will send
processing results back to M-Files.

Working with a Workflow in M-Files
To send a file to ABBYY FlexiCapture, open the M-Files client and do the following:

1. Move the file to the required document vault, right-click it, and click Workflow →Change State….

2. Specify a workflow and state transition and click OK.

The foregoing script will send a batch to ABBYY FlexiCapture. This batch will have predefined

registration parameters assigned to it. These registration parameters will contain the following

information:

· Repository – the document vault from which the document was sent;

Note:  The "export from FlexiCapture" script does not use the Repository parameter.

· FolderPath – the object type name in the M-Files document vault;

· Template – the class name in the M-Files object type;

· FileName – the value set as the name property of the document.

You can use the values of these registration parameters to update the original M-Files document. For

detailed instructions on using tags, please see Specifying export settings and mapping fields.

Please see FlexiCapture 12 Distributed Administrator's Help for detailed information regarding

Registration parameters.

When FlexiCapture receives the file, processing will begin. During the processing, the file will be sent to

first to the verification stage (if verification is set up) and then to the export stage. At the export stage,

ABBYY FlexiCapture will add the captured fields to the document and send the document back to M-

Files.

http://help.abbyy.com/en-us/flexicapture/12/distributed_administrator/reg_params
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